Este artigo foi traduzido por máquina. Para visualizar o arquivo em inglês, marque a caixa de seleção Inglês. Você também pode exibir o texto Em inglês em uma janela pop-up, movendo o ponteiro do mouse sobre o texto.
Tradução
Inglês

Requisitos do sistema do .NET Framework

 

As tabelas neste tópico fornecem o hardware, sistema operacional e os requisitos de software para o .NET Framework 4.5 e os lançamentos pontuais (4.5.1 e 4.5.2), bem como a .NET Framework 4.6 e suas versões de ponto (4.6.1 e 4.6.2). Ambientes de desenvolvimento que permitem que você desenvolva aplicativos para o .NET Framework tem um conjunto separado de requisitos.

Para baixar informações e links, consulte Instalando o .NET Framework.

Para obter informações sobre o ciclo de vida de suporte de versões do .NET Framework, consulte ciclo de vida do suporte Microsoft.

Processador

1 GHz

RAM

512 MB

Espaço em disco (mínimo)

      32 bits

4.5 GB

      64 bits

4.5 GB

  • O .NET Framework requer privilégios de administrador para instalar. Se você não tiver direitos de administrador no computador no qual você gostaria de instalar o .NET Framework, entre em contato com o administrador da rede.

Sistema Operacional

Edições com suporte

Com o sistema operacional pré-instalado

Pode ser instalado separadamente

Atualização de Aniversário do Windows 10

32 bits e 64 bits

.NET Framework 4.6.2

Atualização de novembro 10 do Windows

32 bits e 64 bits

.NET Framework 4.6.1

Windows 10

32 bits e 64 bits

.NET Framework 4.6

.NET Framework 4.6.1

Windows 8.1

32 bits, 64 bits e ARM

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows 8

32 bits, 64 bits e ARM

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

Windows 7 SP1

32 bits e 64 bits

--

.NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows Vista SP2

32 bits e 64 bits

--

.NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

Windows XP

32 bits e 64 bits

--

.NET Framework 4

Observações:

  • Em sistemas Windows 7, o .NET Framework requer o Windows 7 SP1. Se você estiver no Windows 7 e ainda não tiver instalado o Service Pack 1, você precisará fazer isso antes de instalar o .NET Framework.

  • O .NET Framework 4.5 é compatível com o Windows Preinstallation Environment (Windows PE). Nem todos os recursos são suportados no Windows PE.

  • O .NET Framework 4 também oferece suporte a plataforma IA64.

  • Para todas as plataformas, recomendamos que você atualize para o Service Pack mais recente do Windows e instale as atualizações críticas disponíveis no site Windows Update para garantir a melhor compatibilidade e segurança.

  • Em sistemas operacionais de 64 bits, o .NET Framework oferece suporte a ambos WOW64 (processamento 32 bits em um computador 64 bits) e o processamento nativo em 64 bits.

Sistema Operacional

Edições com suporte

Com o sistema operacional pré-instalado

Pode ser instalado separadamente

Windows Server 2016

64 bits

.NET Framework 4.6.2

Windows Server 2012 R2

64 bits

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows Server 2012 (edição de 64 bits)

64 bits

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows Server 2008 R2 SP1

64 bits

--

.NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows Server 2008 SP2

32 bits e 64 bits

--

.NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

Observações:

  • Windows Server 2012 inclui o .NET Framework 4.5, portanto, você não precisa instalá-lo separadamente. Da mesma forma, Windows Server 2012 R2 inclui o .NET Framework 4.5.1.

  • O .NET Framework é suportado na função Server Core no Windows Server 2008 R2 SP1 ou posterior, mas não tem suporte no Windows Server 2008 R2 para sistemas baseados em Itanium.

  • Não há suporte para Windows Server 2008 SP2, o .NET Framework na função Server Core.

  • Para todas as plataformas, recomendamos que você atualizar para o Service Pack mais recente do Windows e atualizações críticas disponíveis a partir de site Windows Update para garantir a melhor compatibilidade e segurança. Instalação do Windows Service Pack mais recente pode ser necessário em alguns sistemas operacionais.

  • Em sistemas operacionais de 64 bits, o .NET Framework oferece suporte a ambos WOW64 (processamento 32 bits em um computador 64 bits) e o processamento nativo em 64 bits.

Mostrar: