Export (0) Print
Expand All

Upgrading XNA Game Studio Projects

Guides for upgrading XNA Game Studio Projects are provided in the following sections:

In This Section

Upgrade Guide: XNA Game Studio 3.0 to XNA Game Studio 3.1
Describes how to upgrade your XNA Game Studio 3.0 game to XNA Game Studio 3.1 in Microsoft Visual Studio 2008.
Upgrade Guide: XNA Game Studio 2.0 to XNA Game Studio 3.1
Describes how to upgrade your XNA Game Studio 2.0 game to XNA Game Studio 3.1 in Microsoft Visual Studio 2008.
Upgrade Guide: XNA Game Studio 2.0 to XNA Game Studio 3.0
Describes how to upgrade your XNA Game Studio 2.0 game to target XNA Framework 3.0 in Microsoft Visual Studio 2008.
Troubleshooting Upgrades
Describes common issues with upgrading XNA Game Studio projects.

Choosing an XNA Framework Version

XNA Framework 3.0 and 3.1

XNA Game Studio 3.1 supports both XNA Game Studio 3.1 and XNA Game Studio 3.0 project formats. To target XNA Framework 3.1, use an XNA Game Studio 3.1 project. XNA Game Studio 3.0 projects will target XNA Framework 3.0.

Dd904224.note(en-us,XNAGameStudio.31).gifImportant
You should not mix projects that target different versions of the XNA Framework in the same solution.

Unless you have a special need to maintain an XNA Game Studio 3.0 project, you should upgrade your projects to XNA Game Studio 3.1 to take advantage of the new features in this release. For more information, see What's New in XNA Game Studio 3.1.

XNA Game Studio 3.1 projects must use the Microsoft Cross Platform Audio Creation Tool version 3 (XACT3), which is new to XNA Game Studio 3.1. The version of XACT provided with XNA Game Studio 3.0, XACT2, writes project files (.xap) that are incompatible with XNA Game Studio 3.1 projects. XNA Game Studio 3.0 projects must continue to use XACT2. Both versions of XACT are available in the Start menu, under All Programs | Microsoft XNA Game Studio 3.1 | Tools.

XNA Framework 2.0

XNA Game Studio 2.0 projects, targeting XNA Framework 2.0, are not supported in this release. All XNA Game Studio 2.0 projects must be upgraded to target either XNA Framework 3.1 or XNA Framework 3.0.

For more information about upgrading XNA Game Studio 2.0 projects, see Upgrade Guide: XNA Game Studio 2.0 to XNA Game Studio 3.0.

Community Additions

ADD
Show:
© 2015 Microsoft