문서를 영문으로 보려면 영문 확인란을 선택하세요. 마우스 포인터를 텍스트 위로 이동시켜 팝업 창에서 영문 텍스트를 표시할 수도 있습니다.
번역
영문

<startup> 요소

 

공용 언어 런타임 시작 정보를 지정합니다.

<startup useLegacyV2RuntimeActivationPolicy="true|false" > 
</startup>

특성 및 요소

다음 단원에서는 특성, 자식 요소 및 부모 요소에 대해 설명합니다.

특성

attribute

설명

useLegacyV2RuntimeActivationPolicy

선택적 특성입니다.

.NET Framework 2.0 런타임 정품 인증 정책을 활성화할지 또는 .NET Framework 4 정품 인증 정책을 사용할지 여부를 지정합니다.

useLegacyV2RuntimeActivationPolicy 특성

설명

True

레거시 런타임 활성화 기술(예: CorBindToRuntimeEx function)을 CLR 버전 2.0에 캐핑하는 대신 구성 파일에서 선택한 런타임에 바인딩하는 .NET Framework 2.0 런타임 활성화 정책을 선택한 런타임에 사용하도록 설정합니다. 따라서 이전 버전의 .NET Framework를 사용하여 만든 혼합 모드 어셈블리인 구성 파일에서 CLR 버전 4 이상을 선택하는 경우 .NET Framework는 선택된 CLR 버전으로 로드됩니다. 이 값을 설정하면 CLR 버전 1.1 또는 CLR 버전 2.0이 같은 프로세스로 로드되지 않아 in-process side-by-side 기능이 효과적으로 비활성화됩니다.

false

.NET Framework 4에 레거시 런타임 활성화 기술에서 CLR 버전 1.1 또는 2.0을 프로세스로 로드를 허용하는 기본 활성화 정책을 사용합니다. 이 값을 설정하면 복합 모드 어셈블리가 .NET Framework 4 이상으로 빌드되지 않은 이상 .NET Framework 4 이상으로 로드되지 않습니다. 이 값이 기본값입니다.

자식 요소

요소

설명

<requiredRuntime>

응용 프로그램이 공용 언어 런타임 버전 1.0만 지원하도록 지정합니다. 런타임 버전 1.1 이상으로 작성된 응용 프로그램은 <supportedRuntime> 요소를 사용해야 합니다.

<supportedRuntime>

응용 프로그램이 지원하는 공용 언어 런타임 버전을 지정합니다.

부모 요소

요소

설명

configuration

공용 언어 런타임 및 .NET Framework 응용 프로그램에서 사용하는 모든 구성 파일의 루트 요소입니다.

<supportedRuntime> 요소는 런타임 버전 1.1 이상으로 작성된 모든 응용 프로그램에서 사용되어야 합니다. 런타임 버전 1.0만 지원하도록 작성된 응용 프로그램은 <requiredRuntime> 요소를 사용해야 합니다.

Microsoft Internet Explorer에 호스팅되는 응용 프로그램의 시작 코드는 <startup> 요소 및 그 자식 요소를 무시합니다.

이 속성은 응용 프로그램이 CorBindToRuntimeEx 함수와 같은 레거시 활성화 경로를 사용하면서 해당 경로로 CLR 4 이후 버전을 활성화하려는 경우 또는 응용 프로그램이 .NET Framework 4로 빌드되었지만 이전 버전의 .NET Framework로 빌드된 혼합 모드 어셈블리에 종속성이 있는 경우에 유용합니다. 그러한 시나리오에서는 속성을 true로 설정합니다.

System_CAPS_note참고

특성을 true로 설정하면 CLR 버전 1.1 또는 CLR 버전 2.0이 같은 프로세스로 로드되지 않아 in-process side-by-side 기능이 효과적으로 비활성화됩니다(Side-by-Side Execution for COM Interop 참조).

예제

다음 예제에서는 구성 파일에 런타임 버전을 지정하는 방법을 보여 줍니다.

<!-- When used with version 1.0 of the .NET Framework runtime -->
<configuration>
   <startup>
      <requiredRuntime version="v1.0.3705" safemode="true"/>
   </startup>
</configuration>
<!-- When used with version 1.1 (or later) of the runtime -->
<configuration>
   <startup>
      <supportedRuntime version="v1.1.4322"/>
      <supportedRuntime version="v1.0.3705"/>
   </startup>
</configuration>
표시: