情報
要求されたトピックは次のとおりです。しかし、このトピックはこのライブラリには含まれていません。

Windows Phone 8 の新しいアプリケーション プロジェクトの対象バージョンを指定する方法

2014/06/18

Windows Phone SDK 8.0 で新しい Windows Phone アプリケーションやゲームを作成するときに、対象を Windows Phone 8 にするか Windows Phone OS 7.1 にするかを指定できます。詳細については、「Windows Phone のバージョン」を参照してください。

既存の Windows Phone OS 7.1 アプリケーションやライブラリ プロジェクトを開くときに、アプリケーションの対象を Windows Phone 8 にアップグレードすることも、Windows Phone OS 7.1 のままにすることもできます。詳細については、「アプリ プロジェクトを Windows Phone 8 にアップグレードする方法」を参照してください。

また、対象バージョンが異なる複数のプロジェクトを含むソリューションを作成することもできます。そうすることで、Windows Phone 8 と Windows Phone OS 7.1 の両方を対象とするアプリケーションの保守が容易になります。詳細については、「Windows Phone 8 でアプリの複数のバージョンをターゲットにする方法」を参照してください。

異なるバージョンの Windows Phone を対象とする複数のプロジェクトは、どのソリューションにでも含めることができます。複数プロジェクトのソリューションでは、Windows Phone 8 プロジェクトで Windows Phone OS 7.1 プロジェクトを参照することはできますが、Windows Phone OS 7.1 プロジェクトで Windows Phone 8 を対象とするプロジェクトを参照することはできません。詳細については、「Windows Phone のバージョン」を参照してください。

新しい Windows Phone アプリケーション プロジェクトを作成するときに、Visual Studio の Windows Phone プラットフォームの選択ダイアログ ボックスで対象バージョンを選択します。

新しい Windows Phone プロジェクトの対象バージョンを設定するには

  1. Visual Studio で、[ファイル] メニューの [新しいプロジェクト] をクリックします。

    [新しいプロジェクト] ダイアログ ボックスが表示されます。

  2. [インストールされたテンプレート] ボックスの一覧から、使用するプログラミング言語を選択します。選択できる言語は、Visual C#Visual Basic、または Visual C++ です。次に、[Windows Phone] カテゴリを選択します。

    指定した言語で Windows Phone アプリを開発する際に使用できるプロジェクト テンプレートの一覧が表示されます。

  3. 使用できるプロジェクト テンプレートの一覧からテンプレートを選択します。使用できるテンプレートの詳細については、「Windows Phone 8 用のテンプレートから新しいアプリ プロジェクトを作成する方法」を参照してください。

  4. ダイアログ ボックスの下部で、プロジェクトの名前とファイル システムの場所を選択します。[OK] をクリックします。

    次の図に示すように、Windows Phone プラットフォームの選択ダイアログ ボックスが表示されます。

    platform picker dialog

    Windows Phone SDK 8.0 で追加された新しいテンプレートの 1 つを使用してプロジェクトを作成する場合、このダイアログ ボックスは表示されません。これらのプロジェクトは常に Windows Phone 8 を対象としています。

  5. Windows Phone プラットフォームの選択ダイアログ ボックスで、アプリで対象とする Windows Phone プラットフォームを選択します。選択できるプラットフォームは Windows Phone 8 または Windows Phone OS 7.1 です。[OK] をクリックします。

表示: