Esta documentación está archivada y no tiene mantenimiento.

HttpCapabilitiesBase.JavaApplets (Propiedad)

Actualización: noviembre 2007

Obtiene un valor que indica si el explorador admite Java.

Espacio de nombres:  System.Web.Configuration
Ensamblado:  System.Web (en System.Web.dll)

public bool JavaApplets { get; }
/** @property */
public boolean get_JavaApplets()

public function get JavaApplets () : boolean

Valor de propiedad

Tipo: System.Boolean
Es true si el explorador admite Java; en caso contrario, es false. El valor predeterminado es false.

En el ejemplo de código siguiente se muestra cómo determinar si el explorador admite Java.

<%@ page language="C#"%>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<script runat="server">
    void Page_Load(Object Sender, EventArgs e)
    {
        CheckBrowserCaps();
    }

    void CheckBrowserCaps()
    {
        String labelText = "";
        System.Web.HttpBrowserCapabilities myBrowserCaps = Request.Browser;
        if (((System.Web.Configuration.HttpCapabilitiesBase)myBrowserCaps).JavaApplets)
        {
            labelText = "Browser supports Java applets.";
        }
        else
        {
            labelText = "Browser does not support Java applets.";
        }

        Label1.Text = labelText;
    }
</script>

<html xmlns="http://www.w3.org/1999/xhtml" >
<head>
    <title>Browser Capabilities Sample</title>
</head>
<body>
    <form runat="server" id="form1">
        <div>
            Browser Capabilities:
            <p/><asp:Label ID="Label1" Runat="server" />
        </div>
    </form>
</body>
</html>


Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98

.NET Framework y .NET Compact Framework no admiten todas las versiones de cada plataforma. Para obtener una lista de las versiones compatibles, vea Requisitos de sistema de .NET Framework.

.NET Framework

Compatible con: 3.5, 3.0, 2.0
Mostrar: