Esta documentación está archivada y no tiene mantenimiento.

NotSupportedException (Clase)

Actualización: noviembre 2007

Excepción que se produce cuando no se admite un método invocado o cuando se intenta leer, buscar o escribir en una secuencia que no admite la funcionalidad invocada.

Espacio de nombres:  System
Ensamblado:  mscorlib (en mscorlib.dll)

[SerializableAttribute]
[ComVisibleAttribute(true)]
public class NotSupportedException : SystemException
/** @attribute SerializableAttribute */ 
/** @attribute ComVisibleAttribute(true) */
public class NotSupportedException extends SystemException
public class NotSupportedException extends SystemException

Existen métodos que no se admiten en la clase base porque se espera que se implementen en la clase derivada. La clase derivada podría implementar sólo un subconjunto de los métodos de la clase base y producir NotSupportedException para los métodos no admitidos.

Las clases System.IO también producen NotSupportedException siempre que se intenta leer, buscar o escribir en una secuencia que no admite la funcionalidad invocada.

En escenarios donde a veces es posible que el objeto realice la operación solicitada y el estado del objeto determina si la operación se puede realizar, vea InvalidOperationException.

NotSupportedException utiliza HRESULT COR_E_NOTSUPPORTED, que tiene el valor 0x80131515.

Para obtener una lista con los valores de propiedad iniciales de una instancia de NotSupportedException, vea los constructores NotSupportedException.

Todos los miembros static (Shared en Visual Basic) públicos de este tipo son seguros para la ejecución de subprocesos. No se garantiza que los miembros de instancias sean seguros para la ejecución de subprocesos.

Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98, Windows CE, Windows Mobile para Smartphone, Windows Mobile para Pocket PC, Xbox 360

.NET Framework y .NET Compact Framework no admiten todas las versiones de cada plataforma. Para obtener una lista de las versiones compatibles, vea Requisitos de sistema de .NET Framework.

.NET Framework

Compatible con: 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Compatible con: 3.5, 2.0, 1.0

XNA Framework

Compatible con: 2.0, 1.0
Mostrar: