This documentation is archived and is not being maintained.

CspParameters Constructor (Int32, String, String)

Initializes a new instance of the CspParameters class with the specified provider type code and name, and the specified container name.

Namespace:  System.Security.Cryptography
Assembly:  mscorlib (in mscorlib.dll)

public CspParameters(
	int dwTypeIn,
	string strProviderNameIn,
	string strContainerNameIn
)

Parameters

dwTypeIn
Type: System.Int32

The provider type code that specifies the kind of provider to create.

strProviderNameIn
Type: System.String

A provider name.

strContainerNameIn
Type: System.String

A container name.

Use the CspParameters constructor to specify a provider type, a provider name, and a container name.

You can use the container name to retrieve a key within that container.

Specify a provider type by passing a numeric value that represents the desired provider type. The numeric values that represent the default provider types are defined in the WinCrypt.h header file:

  • To specify a provider compatible with the RSA algorithm, pass a value of 1to the dwTypeIn parameter.

  • To specify a provider compatible with the DSA algorithm, pass a value of 13to the dwTypeIn parameter.

For information about other provider type values, see the ProviderType field. For more information about the default provider types and their behaviors, see the Microsoft Cryptography API (CAPI) documentation in the MSDN library.

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98, Windows CE, Windows Mobile for Smartphone, Windows Mobile for Pocket PC

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0
Show: