Summary of Changes Required to Port an Intermediate Driver to NDIS 6.30

To update an NDIS 6.x intermediate (IM) driver to support NDIS 6.30, you must modify it as outlined in the following sections.

Build Environment

  • Replace the preprocessor definition NDIS60 or NDIS61 or NDIS620, if present, with NDIS630.
  • Update the major and minor NDIS version number in the NDIS_Xxx_DRIVER_CHARACTERISTICS structure as described in Implementing an NDIS 6.30 Driver.

General Porting Requirements

 

 

Send comments about this topic to Microsoft

Show:
© 2015 Microsoft