Provider::ValidatePutInstanceFlags method

[The Provider class is part of the WMI Provider Framework which is now considered in final state, and no further development, enhancements, or updates will be available for non-security related issues affecting these libraries. The MI APIs should be used for all new development.]

The ValidatePutInstanceFlags method determines whether a set of flags is valid for an instance update operation.

Syntax


HRESULT ValidatePutInstanceFlags(
   long lFlags
);

Parameters

lFlags

Bitmask of flags that are validated.

Return value

Returns WBEM_S_NO_ERROR if the flags are valid and WBEM_E_UNSUPPORTED_PARAMETER if one or more flags are not valid.

Remarks

Framework providers can override this method to validate flags that are unknown to the base Provider class.

At present, the Provider class supports the following update flags:

  • WBEM_FLAG_CREATE_ONLY
  • WBEM_FLAG_CREATE_OR_UPDATE
  • WBEM_FLAG_UPDATE_ONLY

Requirements

Minimum supported client

Windows Vista

Minimum supported server

Windows Server 2008

Header

Provider.h (include FwCommon.h)

Library

FrameDyn.lib

DLL

FrameDynOS.dll;
FrameDyn.dll

 

 

Show: