WebItem Class

Enables upgraded Visual Basic 6.0 WebClass projects to run in ASP.NET.

Namespace:  Microsoft.VisualBasic.Compatibility.VB6
Assembly:  Microsoft.VisualBasic.Compatibility (in Microsoft.VisualBasic.Compatibility.dll)

public class WebItem

When a Visual Basic 6.0 WebClass project is upgraded to Visual Basic 2008, it is converted to an ASP.NET Web site project.

Declarations are added to your project: one for the WebClass and one for each of the WebItems and Templates in the WebClass project. A Page_Load event procedure is added to the project, creating first a WebClass object and then WebItem objects for each of the WebItems and Templates associated with the Visual Basic 6.0 WebClass project. Finally, in the Page_Load event procedure, you will see a call to the WebClass Compatibility runtime: ProcessEvents. This enables the runtime to render the WebItem specified in the Request URL. This code is the only new code added to your upgraded project and only serves to emulate the underlying behavior of the Visual Basic 6.0 WebClass runtime.

NoteNote:

Functions and objects in the Microsoft.VisualBasic.Compatibility.VB6 namespace are provided for use by the tools for upgrading from Visual Basic 6.0 to Visual Basic 2008. In most cases, these functions and objects duplicate functionality that you can find in other namespaces in the .NET Framework. They are necessary only when the Visual Basic 6.0 code model differs significantly from the .NET Framework implementation.

System.Object
  Microsoft.VisualBasic.Compatibility.VB6.WebItem

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 3.5, 3.0, 2.0
Was this page helpful?
(1500 characters remaining)
Thank you for your feedback

Community Additions

ADD
Show:
© 2015 Microsoft