This documentation is archived and is not being maintained.

TraceSwitch.TraceWarning Property

Gets a value indicating whether the switch allows warning messages.

Namespace:  System.Diagnostics
Assembly:  System (in System.dll)

public bool TraceWarning { get; }

Property Value

Type: System.Boolean
true if the Level property is set to TraceLevel.Warning, TraceLevel.Info, or TraceLevel.Verbose; otherwise, false.

You can use the TraceError, TraceWarning, TraceInfo, and TraceVerbose properties in conjunction with the Debug and Trace classes to emit all messages with a specified importance or greater. When the Level property is set to TraceLevel.Warning, warnings and error-handling messages are emitted.

The following code example creates a new TraceSwitch and uses the switch to determine whether to emit error messages. The switch is created at the class level. MyMethod writes the first error message if the Level property is set to TraceLevel.Warning or higher. However, MyMethod does not write the second error message when the Level is less than TraceLevel.Verbose.

//Class-level declaration. 
 /* Create a TraceSwitch to use in the entire application.*/ 
 static TraceSwitch mySwitch = new TraceSwitch("General", "Entire Application");

 static public void MyMethod() {
    // Write the message if the TraceSwitch level is set to Warning or higher. 
    if(mySwitch.TraceWarning)
       Console.WriteLine("My error message.");

    // Write the message if the TraceSwitch level is set to Verbose. 
    if(mySwitch.TraceVerbose)
       Console.WriteLine("My second error message.");
 }

 public static void Main(string[] args) {
    // Run the method that prints error messages based on the switch level.
    MyMethod();
 }

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 3.5, 3.0, 2.0, 1.1, 1.0
Show: