This documentation is archived and is not being maintained.

IRowsetInfo Interface

Note: This API is now obsolete.

Provides an implementation of the OLE DB IRowsetInfo interface for use by applications upgraded from Visual Basic 6.0.

Namespace:  Microsoft.VisualBasic.Compatibility.VB6
Assembly:  Microsoft.VisualBasic.Compatibility.Data (in Microsoft.VisualBasic.Compatibility.Data.dll)

[ObsoleteAttribute("Microsoft.VisualBasic.Compatibility.* classes are obsolete and supported within 32 bit processes only. http://go.microsoft.com/fwlink/?linkid=160862")]
[GuidAttribute("0C733A55-2A1C-11CE-ADE5-00AA0044773D")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIUnknown)]
public interface IRowsetInfo

The IRowsetInfo type exposes the following members.

  NameDescription
Public methodGetPropertiesReturns the current settings of all properties supported by the rowset.
Public methodGetReferencedRowsetReturns an interface pointer to the rowset to which a bookmark or chapter applies.
Public methodGetSpecificationReturns an interface pointer on the object (command or session) that created this rowset.
Top

NoteNote

Functions and objects in the Microsoft.VisualBasic.Compatibility.VB6 namespace are provided for use by the tools for upgrading from Visual Basic 6.0 to Visual Basic 2010. In most cases, these functions and objects duplicate functionality that you can find in other namespaces in the .NET Framework. They are necessary only when the Visual Basic 6.0 code model differs significantly from the .NET Framework implementation.

.NET Framework

Supported in: 3.5, 3.0, 2.0
Obsolete (compiler warning) in 4

.NET Framework Client Profile

Obsolete (compiler warning) in 4

Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.
Show: