IMigrator interface

NOTE: This API is now obsolete.

Provides an interface that encapsulates a migrator delegate.

Namespace:  Microsoft.SharePoint.Upgrade
Assembly:  Microsoft.SharePoint (in Microsoft.SharePoint.dll)

[ObsoleteAttribute("Gradual Upgrade is not supported in the current version of SharePoint.")]
[SharePointPermissionAttribute(SecurityAction.InheritanceDemand, ObjectModel = true)]
[SharePointPermissionAttribute(SecurityAction.LinkDemand, ObjectModel = true)]
public interface IMigrator
Show: