RequiredPlatformVersion Element (Visual Studio Templates)

 

For the latest documentation on Visual Studio 2017, see Visual Studio 2017 Documentation.

Specifies the minimum version of the operating system that the project template requires to work correctly. This element is used to for project templates that create Windows 8.x Store apps.

The RequiredPlatformVersion value is compared directly with the version of the operating system. If the RequiredPlatformVersion is higher than the operating system version, the template does not appear in the New Project dialog box. To specify a template for Windows 8 or higher, set RequiredPlatformVersion to 6.2.0. To specify a template for Windows 8.1 or higher, set RequiredPlatformVersion to 6.3.0.

Templates that specify RequiredPlatformVersion=8 are compatible with previous customer Windows 8.x Store templates.

VSTemplate
TemplateData
…..TargetPlatformName
RequiredPlatformVersion

<RequiredPlatformVersion> OperatingSystem </RequiredPlatformVersion>  

None.

Attributes

None.

Child Elements

None.

Parent Elements

ElementDescription
TemplatePlatformNameSpecifies the platform that the project template targets.

A text value is required.

This text specifies the minimum operating system version required by the template.

This example specifies that the project template targets Windows 8 or later.

<VSTemplate Type="Project" Version="3.0.0"    xmlns="http://schemas.microsoft.com/developer/vstemplate/2005">  
    <TemplateData>  
        <TargetPlatformName>Windows</TargetPlatformName>  
            <RequiredPlatformVersion>6.3.0</RequiredPlatformVersion>  
  
    </TemplateData>  
    <TemplateContent>  
  
    </TemplateContent>  
</VSTemplate>  

TargetPlatformName Element (Visual Studio Templates)
Creating Project and Item Templates
Visual Studio Template Schema Reference

Show: