Troubleshooting Upgrades

Troubleshooting Upgrades

Projects do not build because a reference to assembly version X is missing, but I am not targeting X.

Check the dependencies of all assemblies included with your projects. Also, ensure that any assemblies you're using in your projects target the same version of the XNA Framework that your project is targeting. Projects (or libraries) that target different versions of the XNA Framework cannot interact and should not be located in the same solution.

Projects do not build because a type cannot be converted (from assembly version X to assembly version Y).

Check to see that all classes in your project use the classes, methods, properties, and events that exist in the XNA Framework version you are targeting. In some cases, methods may have been deprecated or some parameters may have changed.

My importer or processor is missing from the list of importers or processors available in the Content Pipeline.

The importer or processor used by your project may not support the version of XNA Framework that you are targeting. Ensure you have updated versions of all components used by your title.

My content will not build because the importer or processor cannot be found, but I have a reference to it.

The importer or processor used by your project may not support the version of XNA Framework that you are targeting. Ensure you have updated versions of all components used by your title.

Community Additions

ADD
Show:
© 2016 Microsoft