ShouldSerializeElementInTargetVersion Method

ConfigurationSection::ShouldSerializeElementInTargetVersion Method (ConfigurationElement^, String^, FrameworkName^)

.NET Framework (current version)
 

Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework.

Namespace:   System.Configuration
Assembly:  System.Configuration (in System.Configuration.dll)

public protected:
virtual bool ShouldSerializeElementInTargetVersion(
	ConfigurationElement^ element,
	String^ elementName,
	FrameworkName^ targetFramework
)

Parameters

element
Type: System.Configuration::ConfigurationElement^

The ConfigurationElement object that is a candidate for serialization.

elementName
Type: System::String^

The name of the ConfigurationElement object as it occurs in XML.

targetFramework
Type: System.Runtime.Versioning::FrameworkName^

The target version of the .NET Framework.

Return Value

Type: System::Boolean

true if the element should be serialized; otherwise, false.

Each configuration section that is created for the .NET Framework 4 and later versions must explicitly override this method and return true, but only if the specified element is valid for the specified version of the .NET Framework. Existing configuration sections that were created for earlier versions of the .NET Framework do not have to be changed.

The base type contains a default implementation of this method that always returns true. If you implement a configuration section and you do not override this method, by default all configuration elements that are contained in the configuration section will be serialized for all framework versions.

.NET Framework
Available since 4.0
Return to top
Show:
© 2016 Microsoft