Export (0) Print
Expand All

SupportedRuntimes Property

Specifies the version or versions of the common language runtime that must be present on a target computer in order for a .NET Framework launch condition to succeed. Defaults to the runtime version shipped with the version of Visual Studio that you are using.

Multiple versions can be specified by separating them with semicolons; the first version found (in the order listed) will cause the launch condition to succeed.

NoteNote:

If your deployment project includes custom actions that have a dependency on the .NET Framework, the first version found (in the order listed) will be loaded to run the custom action. For this reason, you should list the most recent version first.

In general, .NET Framework applications require the same runtime version that they were built against. You should only override the default setting if you have thoroughly tested your application against any versions that you specify.

Caution noteCaution:

If you override this property, you may need to modify the InstallUrl property as well; otherwise, the user will be redirected to a Web page that contains the wrong runtime version. For more information, see InstallUrl Property (Launch Conditions).

Community Additions

Show:
© 2015 Microsoft