This documentation is archived and is not being maintained.

OracleParameterCollection.Add Method (String, Object)

NOTE: This API is now obsolete.

Adds an OracleParameter to the OracleParameterCollection given the parameter name and value.

Namespace:  System.Data.OracleClient
Assembly:  System.Data.OracleClient (in System.Data.OracleClient.dll)

[ObsoleteAttribute("Add(String parameterName, Object value) has been deprecated.  Use AddWithValue(String parameterName, Object value).  http://go.microsoft.com/fwlink/?linkid=14202", 
	false)]
public OracleParameter Add(
	string parameterName,
	Object value
)

Parameters

parameterName
Type: System.String

The name of the parameter.

value
Type: System.Object

The Value of the OracleParameter to add to the collection.

Return Value

Type: System.Data.OracleClient.OracleParameter
A reference to the new OracleParameter object.

ExceptionCondition
InvalidCastException

The value parameter is not an OracleParameter.

Use caution when using this overload of the Add method to specify integer parameter values. Because this overload takes a value of type Object, you must convert the integral value to an Object type when the value is zero, as the following C# example demonstrates.

parameters.Add("pname", Convert.ToInt32(0));

If you do not perform this conversion, the compiler will assume you are attempting to call the OracleParameterCollection.Add (string, OracleType) overload.

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 1.1
Obsolete (compiler warning) in 3.5
Obsolete (compiler warning) in 3.5 SP1
Obsolete (compiler warning) in 3.0
Obsolete (compiler warning) in 3.0 SP1
Obsolete (compiler warning) in 3.0 SP2
Obsolete (compiler warning) in 2.0
Obsolete (compiler warning) in 2.0 SP1
Obsolete (compiler warning) in 2.0 SP2
Show: