What's New in POS for .NET v1.1

2/27/2008

POS for .NET 1.1 provides support for version 1.9 of the Unified Point of Service (UPOS) industry specification, as well as:

  • Enhanced support for legacy COM interoperability
  • Support for version 2.0 of the .NET Framework

The UPOS specification is a common architecture that all POS applications share. It is platform, hardware, and language independent and is the basis for nearly all POS design. Version 1.1 brings POS for .NET support of UPOS functionality up-to-date with the current version of UPOS, 1.9.

POS for .NET 1.1 supports legacy COM interoperability for the following device classes:

  • Cash Drawer
  • Check Scanner
  • Coin Dispenser
  • Keylock
  • Line Display
  • MICR (Magnetic Ink Character Recognition Reader)
  • MSR (Magnetic Stripe Reader)
  • PIN Pad
  • POS Keyboard
  • POS Power
  • POS Printer
  • Scale
  • Scanner (Bar Code Reader)
  • Signature Capture
  • Tone Indicator

There is no legacy COM interoperability support for the following device classes at this time:

  • Bump Bar
  • Cash Changer
  • CAT (Credit Authorization Terminal)
  • Fiscal Printer
  • Hard Totals
  • Motion Sensor
  • Point Card Reader/Writer
  • Remote Order Display
  • Smart Card Reader/Writer

As new versions of the UPOS specification enter wider use, it is important to ensure that your POS applications dependent on them are supported by an up-to-date version of POS for .NET.

Compatibility scenarios are shown in the following table.

POS for .NET Application Service Object Compatible

POS for .NET 1.1

(synchronized with UPOS v1.9)

UPOS v1.8

UPOS v1.8

Yes

UPOS v1.8

UPOS v1.9

Yes

UPOS v1.9

UPOS v1.8

Yes

UPOS v1.9

UPOS v1.9

Yes

POS for .NET 1.0

(synchronized with UPOS v1.8)

UPOS v1.8

UPOS v1.8

Yes

UPOS v1.8

UPOS v1.9

No

UPOS v1.9

UPOS v1.8

No

UPOS v1.9

UPOS v1.9

No

POS for .NET v1.1 supports version 2.0 of the .NET Framework and is fully compatible with all .NET v2.0 features. It is important to note that Microsoft .NET Framework 2.0 is not distributed with POS for .NET 1.1 and must downloaded separately.

Show: