This documentation is archived and is not being maintained.

minVersionToUpgrade Attribute

Office 2007

Inclusive value for the oldest form that can be upgraded.

Type

              xsf:xdSolutionVersion
            

Remarks

The minVersionToUpgrade attribute is a required attribute of the useTransform element.

The minVersionToUpgrade attribute is used to prevent running the XSL Transformation (XSLT) on forms so different from the current one that the XSLT causes risk of data loss.

Example

The following example shows the minVersionToUpgrade attribute as it is used in the useTransform element:

              <xsf:documentVersionUpgrade>
   <xsf:useTransform
      transform="upgrade.xsl"
      minVersionToUpgrade="0.0.0.0"
      maxVersionToUpgrade="1.0.0.5"/>
</xsf:documentVersionUpgrade>

            


Show: