Export (0) Print
Expand All

System Requirements for the OLE DB Provider for SQL Server

SQL Server 2000

To access data in Microsoft® SQL Server™ 2000, you must have the following software installed:

  • Microsoft OLE DB Provider for SQL Server (SQLOLEDB).

  • An instance of SQL Server.

  • Network software.

OLE DB consumer development requires Microsoft Visual C++® version 5.0.

SQLOLEDB Requirements

SQLOLEDB requires one of the following:

  • Microsoft Windows® 95 or Windows 98 operating system on Intel® computers.

  • Microsoft Windows 2000 or Microsoft Windows NT® 4.0 operating system on Intel computers.
SQL Server Requirements

To use SQLOLEDB to access data in SQL Server databases, you must have an instance of SQL Server 2000 or SQL Server version 6.5 or later installed; the catalog stored procedures must also be installed.

Network Software Requirements

SQLOLEDB communicates with network software through the SQL Server Net-Library interface, which requires a Net-Library dynamic-link library (DLL). The Microsoft OLE DB Provider for SQL Server 2000 requires SQL Server 2000 Net-Library .dll files, which are installed when you run the client portion of SQL Server 2000 Setup.

See Also

Configuring Client Network Connections

Hardware and Software Requirements for Installing SQL Server

Client Net-Libraries and Network Protocols

Upgrading the Catalog Stored Procedures (OLE DB)

Show:
© 2015 Microsoft