Export (0) Print
Expand All

Convert.ToUInt16 Method (Decimal)

Converts the value of the specified decimal number to an equivalent 16-bit unsigned integer.

This API is not CLS-compliant. 

Namespace:  System
Assembly:  mscorlib (in mscorlib.dll)

[CLSCompliantAttribute(false)]
public static ushort ToUInt16(
	decimal value
)

Parameters

value
Type: System.Decimal
The decimal number to convert.

Return Value

Type: System.UInt16
value, rounded to the nearest 16-bit unsigned integer. If value is halfway between two whole numbers, the even number is returned; that is, 4.5 is converted to 4, and 5.5 is converted to 6.

ExceptionCondition
OverflowException

value is less than zero or greater than UInt16.MaxValue.

The following example converts each element in an array of Decimal values to an unsigned 16-bit integer.


decimal[] numbers = { Decimal.MinValue, -1034.23m, -12m, 0m, 147m,
                            9214.16m, Decimal.MaxValue };
ushort result;

foreach (decimal number in numbers)
{
   try {
      result = Convert.ToUInt16(number);
      Console.WriteLine("Converted the {0} value '{1}' to the {2} value {3}.", 
                        number.GetType().Name, number, 
                        result.GetType().Name, result);
   }   
   catch (OverflowException)
   {
      Console.WriteLine("{0} is outside the range of the UInt16 type.",
                        number);
   }   
}                                  
// The example displays the following output:
//    -79228162514264337593543950335 is outside the range of the UInt16 type.
//    -1034.23 is outside the range of the UInt16 type.
//    -12 is outside the range of the UInt16 type.
//    Converted the Decimal value '0' to the UInt16 value 0.
//    Converted the Decimal value '147' to the UInt16 value 147.
//    Converted the Decimal value '9214.16' to the UInt16 value 9214.
//    79228162514264337593543950335 is outside the range of the UInt16 type.


.NET Framework

Supported in: 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1

Portable Class Library

Supported in: Portable Class Library

Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

Community Additions

ADD
Show:
© 2015 Microsoft