rsInvalidReportServerDatabase

New: 12 December 2006

Product Name

SQL Server

Product Version

9.0

Product Build Number

9.00.1399

Event ID

rsInvalidReportServerDatabase

Event Source

Microsoft.ReportingServices.Diagnostics.Utilities.ErrorStrings

Component

Reporting Services

Message Text

The version of the report server database is either in a format that is not valid, or it cannot be read. The found version is 'C.0.8.40'. The expected version is 'C.0.8.43'. To continue, update the version of the report server database and verify access rights. (rsInvalidReportServerDatabase) (ReportingServicesLibrary)

This error indicates that the report server and the report server database are different versions. This error can occur if you upgrade SQL Server 2005 Reporting Services to SP1 and the two components were not upgraded concurrently. In many cases, Setup can upgrade the database schema for you automatically if it has sufficient permissions and the server is available. Permission to update the database requires that the user who ran Setup is a member of the local administrators group on the SQL Server computer. Without this security context, Setup cannot update the report server database and you will have to update it yourself by using the Reporting Services Configuration tool.

This error can also occur when the database has been upgraded and the report server has not. In this case, the found version will be a number that is later than the expected version. If this occurs, you should upgrade the report server or restore a pre-upgraded version of the report server database.

Use the Database Setup page in the Reporting Services Configuration tool upgrade the report server database.

  1. Click Start, point to Programs, point to Microsoft SQL Server 2005, point to Configuration Tools, click Reporting Services Configuration.
  2. Connect to the report server instance.
  3. Click Database Setup.
  4. Click the Upgrade button.

You only have to upgrade the report server database. The report server temporary database will be upgraded automatically.

Community Additions

ADD
Show: