Diese Dokumentation wurde archiviert und wird nicht länger gepflegt.

InvalidProgramException-Klasse

Aktualisiert: November 2007

Die Ausnahme, die ausgelöst wird, wenn ein Programme ungültige MSIL-Befehle (Microsoft Intermediate Language) oder Metadaten enthält. Dies weist im Allgemeinen auf einen Fehler in dem Compiler hin, der das Programm generiert hat.

Namespace:  System
Assembly:  mscorlib (in mscorlib.dll)

[SerializableAttribute]
[ComVisibleAttribute(true)]
public sealed class InvalidProgramException : SystemException
/** @attribute SerializableAttribute */ 
/** @attribute ComVisibleAttribute(true) */
public final class InvalidProgramException extends SystemException
public final class InvalidProgramException extends SystemException

InvalidProgramException verwendet HRESULT COR_E_INVALIDPROGRAM mit dem Wert 0x8013153A.

Eine Liste der anfänglichen Eigenschaftenwerte für eine Instanz von InvalidProgramException finden Sie unter InvalidProgramException-Konstruktoren.

Weitere Informationen über InvalidProgramException finden Sie unter http://support.microsoft. in der Microsoft Knowledge Base im Artikel Q312544, "What to Do If You Receive an InvalidProgramException Error Message" (nur auf Englisch verfügbar).

System.Object
  System.Exception
    System.SystemException
      System.InvalidProgramException

Alle öffentlichen static (Shared in Visual Basic)-Member dieses Typs sind threadsicher. Bei Instanzmembern ist die Threadsicherheit nicht gewährleistet.

Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98, Windows CE, Windows Mobile für Smartphone, Windows Mobile für Pocket PC, Xbox 360

.NET Framework und .NET Compact Framework unterstützen nicht alle Versionen sämtlicher Plattformen. Eine Liste der unterstützten Versionen finden Sie unter Systemanforderungen für .NET Framework.

.NET Framework

Unterstützt in: 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Unterstützt in: 3.5, 2.0, 1.0

XNA Framework

Unterstützt in: 2.0, 1.0
Anzeigen: