Tento článek byl přeložený strojově. Pokud chcete zobrazit článek v angličtině, zaškrtněte políčko Angličtina. Anglickou verzi článku můžete také zobrazit v místním okně přesunutím ukazatele myši nad text.
Překlad
Angličtina

.NET – požadavky na systém

 

V tabulkách v tomto tématu najdete hardwaru, operačního systému a požadavky na software pro rozhraní .NET Framework 4.5 a jeho bod uvolní (4.5.1 a 4.5.2) a taky .NET Framework 4.6 a jeho verze bodu (4.6.1 a 4.6.2). Vývojových prostředích, které vám umožní vyvíjet aplikace pro rozhraní .NET Framework mají samostatnou sadu požadavků.

Informace o stažení a odkazy naleznete v tématu Instalace rozhraní .NET Framework.

Informace o životní cyklus podpory verze rozhraní .NET Framework naleznete v tématu životní cyklus podpory společnosti Microsoft.

Procesor

1 GHz

PAMĚŤ RAM

512 MB

Místo na disku (minimum)

      32bitová verze

4.5 GB

      64bitových

4.5 GB

  • Rozhraní .NET Framework vyžaduje oprávnění správce, aby bylo možné nainstalovat. Pokud nemáte práva správce k počítači, na kterém chcete nainstalovat rozhraní .NET Framework, obraťte se na správce sítě.

Operační systém

Podporované edice

Předinstalovat s operačním systémem

Instalovat samostatně

Windows 10 Anniversary Update

32bitové a 64bitové verze

.NET Framework 4.6.2

Aktualizace Windows 10. listopadu

32bitové a 64bitové verze

.NET Framework 4.6.1

Windows 10

32bitové a 64bitové verze

.NET Framework 4.6

.NET Framework 4.6.1

Windows 8.1

32-bit, 64-bit a ARM

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows 8

32-bit, 64-bit a ARM

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

Windows 7 SP1

32bitové a 64bitové verze

--

.NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows Vista SP2

32bitové a 64bitové verze

--

.NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

Windows XP

32bitové a 64bitové verze

--

.NET Framework 4

Poznámky:

  • V systémech Windows 7 vyžaduje rozhraní .NET Framework Windows 7 SP1. Pokud jsou v systému Windows 7 a aktualizaci Service Pack 1 ještě nenainstalovali, musíte tak učinit před instalací rozhraní .NET Framework.

  • .NET Framework 4.5 Je podporována v prostředí Windows Preinstallation Environment (Windows PE). Ne všechny funkce jsou podporovány v systému Windows PE.

  • Rozhraní .NET Framework 4 podporuje také platformě IA64.

  • Pro všechny platformy, doporučujeme upgradovat na nejnovější aktualizaci Service Pack pro systém Windows a nainstalovat důležité aktualizace, které jsou k dispozici webu Windows Update k zajištění nejlepší kompatibility a zabezpečení.

  • V 64bitových operačních systémech rozhraní .NET Framework podporuje WOW64 (32bitová verze zpracování na počítači 64-bit) a nativní 64bitové zpracování.

Operační systém

Podporované edice

Předinstalovat s operačním systémem

Instalovat samostatně

Windows Server 2016

64bitových

.NET Framework 4.6.2

Windows Server 2012 R2

64bitových

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows Server 2012 (64-bit edition)

64bitových

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows Server 2008 R2 SP1

64bitových

--

.NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

Windows Server 2008 SP2

32bitové a 64bitové verze

--

.NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

Poznámky:

  • Windows Server 2012 zahrnuje .NET Framework 4.5, takže nemusíte instalovat samostatně. Podobně Windows Server 2012 R2 zahrnuje .NET Framework 4.5.1.

  • Rozhraní .NET Framework je podporováno v roli Server Core v systému Windows Server 2008 R2 SP1 nebo novější, ale není podporován v systému Windows Server 2008 R2 pro systémy s procesorem Itanium.

  • Windows Server 2008 SP2, rozhraní .NET Framework není podporováno v roli Server Core.

  • Pro všechny platformy, doporučujeme, abyste upgrade na nejnovější aktualizaci Service Pack pro systém Windows a kritické aktualizace dostupné z webu Windows Update k zajištění nejlepší kompatibility a zabezpečení. Instalace nejnovější aktualizaci Service Pack pro systém Windows může být nezbytné v některých operačních systémech.

  • V 64bitových operačních systémech rozhraní .NET Framework podporuje WOW64 (32bitová verze zpracování na počítači 64-bit) a nativní 64bitové zpracování.

Zobrazit: