This article was translated by machine. To view in the article in English, select the English check box. You can also display the English text in a popup window by moving the mouse pointer over the text.
الترجمة
الأصلي
This documentation is archived and is not being maintained.

Soap12FaultCodes.VersionMismatchFaultCode الحقل

Visual Studio 2010

يمثل الإصدار 1.2 بروتوكول بروتوكول SOAP VersionMismatchالخطأ تشير إلى تعليمات برمجية الخدمة ويب XML الرسائل بروتوكول بروتوكول SOAP وفقا لمواصفات بروتوكول بروتوكول SOAP 1.2 من المتوقع، بعد تلقي واحد المطابقة ل بروتوكول بروتوكول SOAP 1.1.

مساحة الاسم:  System.Web.Services.Protocols
التجميع:  System.Web.Services (في System.Web.Services.dll)

public static readonly XmlQualifiedName VersionMismatchFaultCode

SoapException هو تم طرح مع Codeتعيين الخاصية إلى Soap12FaultCodes.VersionMismatchFaultCodeعندما يتم تكوين الخدمة ويب XML قبول طلبات بروتوكول بروتوكول SOAP 1.2 فقط ويتلقى رسالة بروتوكول بروتوكول SOAP 1.1. Likewهوe، إذا كانت الخدمة ويب XML هو تكوينه لقبول 1.1 بروتوكول بروتوكول SOAP فقط الرسائل وتلقيها رسالة بروتوكول بروتوكول SOAP 1.2، SoapExceptionهو طرح مع Codeتعيين خاصية إلى SoapException.VersionMismatchFaultCode. للحصول تشغيل تفاصيل حول تكوين الخدمات ويب من XML، راجع [<topic://cpconConfigurationOptionsForASPNETWebServices>].

كل من SOAP 1.1 و 1.2 تعريف VersionMismatchرموز الخطأ SOAP التي تختلف تشغيل الإصدار بروتوكول SOAP المتوقعة. Th هو حقل يمثل الإصدار بروتوكول بروتوكول SOAP 1.2، بينما الإصدار بروتوكول بروتوكول SOAP 1.1 هو تمثيلها بواسطة VersionMismatchFaultCode. تعيين الحقلين إلى أسماء مؤهل مختلفة، ولكن يمكن فحص من ما إذا كان Codeخاصية هو واحد رموز الخطأ بواسطة استدعاء IsVersionMismatchFaultCodeالأسلوب.

نظام التشغيل Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, الإصدار x64 من نظام التشغيل Windows XP Professional, Windows XP Starter Edition, Windows Server 2008, نظام التشغيل Windows Server 2003, نظام التشغيل Windows Server 2000 المزود بحزمة الخدمة SP4, نظام التشغيل Windows Millennium Edition, نظام التشغيل Windows 98

لا يدعم .NET Framework و .NET Compact Framework كافة الإصدارات الخاصة بكل نظام أساسي. للحصول على قائمة بالإصدارات المدعمة، راجع متطلبات النظام إطار عمل .NET.

.NET Framework

مدعوم في: 4, 3.5, 3.0, 2.0

NET Framework. Client Profile

مدعوم في: 4
إظهار: