EN
Este conteúdo não está disponível no seu idioma mas aqui tem a versão em inglês.

Not Supported in Windows Installer 4.0

The Windows Installer functions, tables, and properties listed on this page are not supported by Windows Installer 4.0 and earlier versions. The absence of a feature from this list does not guarantee that the feature is supported. See the main documentation to determine which Windows Installer version is required for a particular feature. For information about other Windows Installer versions see What's New in Windows Installer.

Windows Installer 4.0 is available for Microsoft Windows Server 2008 and Windows Vista. For a complete list of all Windows Installer versions and redistributables, see Released Versions of Windows Installer.

The following features are not supported in Windows Installer 4.0 and earlier versions.

Installer Functions

Properties

Database Tables

Custom Action Patch Uninstall Option

MsiTransformView<PatchGUID>
msidbCustomActionTypePatchUninstall

System Policy

Callback Function Prototypes

Internal Consistency Evaluators - ICEs

  • ICE92 verifies no component has both the msidbComponentAttributesPermanent and msidbComponentAttributesUninstallOnSupersedence attributes.

Notes

Windows Installer 4.0 cannot perform Multiple Package Installations using transaction processing.

Using Windows Installer 4.0 or earlier versions of the installer, small updates and minor upgrades can fail when using the EnforceUpgradeComponentRules policy or MSIENFORCEUPGRADECOMPONENTRULES property because the update removes a component.

A custom user interface cannot be embedded within the Windows Installer package by using the method described in Using an Embedded UI.

 

 

Conteúdo da Comunidade

Adicionar
Mostrar:
© 2014 Microsoft