SecurityAction Enumeration

July 28, 2014

Note: This API is now obsolete.

Specifies the security actions that can be performed by using declarative security.

Namespace:  System.Security.Permissions
Assembly:  mscorlib (in mscorlib.dll)

[ObsoleteAttribute("SecurityAction is no longer accessible to application code.")]
public enum SecurityAction

Member nameDescription
LinkDemandThe immediate caller is required to have been granted the specified permission.
RequestMinimum Obsolete. The request for the minimum permissions required for code to run. This action can be used only within the scope of the assembly.

This class supports the .NET Framework for Windows Phone library code and is not intended to be used by Windows Phone application code. The class has been marked as obsolete so that it will display a compilation warning. You can use this class in a Windows Phone app, but it will have no effect.

Windows Phone OS

Obsolete (compiler warning) in 8.1
Obsolete (compiler warning) in 8.0
Obsolete (compiler warning) in 7.1
Obsolete (compiler warning) in 7.0

Windows Phone

Show:
© 2014 Microsoft