SALES: 1-800-867-1380

Azure SDK for .NET 2.1 Release Notes

Updated: April 25, 2014

This document contains the release notes for the Azure for .NET SDK 2.1 release and describes how Visual Studio 2010 Will Not Be Supported in Future Versions of the SDK, Side-by-Side Cloud Service Debugging is Not Supported with Projects Built Prior to Version 1.7, and Breaking Changes.

Azure for .NET SDK version number (2.1) is determined by the core Windows Azure service runtime assembly using semantic versioning. Other client libraries packaged inside the Azure SDK for .NET, along with their respective NuGet packages, follow independent versioning based on the semantic versioning scheme.

The Azure SDK for .NET 2.1 includes Azure Storage 2.0.6, Azure Service Bus 2.1, Azure Caching 2.0, and Azure Configuration Manager 2.0.1 libraries. You can also download these libraries from their respective NuGet packages.

For more information related to this release, see the following resources:

We are providing advance notice that the Azure SDK for .NET 2.1 will be the last release of the SDK that will support Visual Studio 2010. The next release of the SDK will add support for Visual Studio 2013 and discontinue support for Visual Studio 2010. You can continue to use Visual Studio 2010 for projects that use Azure SDK for .NET versions 2.1 and earlier.

While version 2.1 of the SDK continues to support Visual Studio 2010, Visual Studio 2012, and Visual Studio 2013 Preview, we recommend that you upgrade your Visual Studio 2010 projects to Visual Studio 2012 or Visual Studio 2013 once this SDK is released. Upgrading your projects now will ensure that you are able to use the latest features of Azure when the next version of the SDK is released.

Side-by-Side Cloud Service Debugging is only supported with Azure SDK for .NET versions 1.7, 1.8, 2.0, and 2.1. For a full debugging experience, projects built using versions prior to version 1.7 must be upgraded. For more information, see Azure Cloud Services Support Lifecycle Policy.

For example, when running a project built on Azure SDK for .NET version 1.6 on a machine with version 2.1 installed, you will see the following error message- "The system is missing a prerequisite to execute the service."

To work around this error, uninstall the compute emulator included in version 2.1 and install the compute emulator for version 1.6. If you do this, however, you will not be able to run an application built on SDK version 2.1 on this machine.

The following are breaking changes in the Azure SDK for .NET 2.1:

  • Creating an ASP.NET MVC 5 Web API project or SPA project in a new Cloud Service in Visual Studio 2013 Preview- When creating these project types through File->New->Azure Cloud Service->ASP.NET Web Application, you must manually add an assembly redirect to ODataLib version 5.5 if you are using the Storage Client Library in your project.  This can be done in one of two ways:

    • Remove and re-add the Storage Client Library NuGet package by right-clicking your project References in Solution Explorer and selecting Manage NuGet Packages

    • Or, add the assembly redirect as called out in the build warning:

      C:\Program Files (x86)\MSBuild\12.0\bin\Microsoft.Common.CurrentVersion.targets(1613,5): warning MSB3247: 
      Found conflicts between different versions of the same dependent assembly. 
      Please add the following binding redirects to the "runtime" node in your application configuration file: 
      <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
        <dependentAssembly>
          <assemblyIdentity name="Microsoft.Data.Edm" culture="neutral" publicKeyToken="31bf3856ad364e35" />
          <bindingRedirect oldVersion="0.0.0.0-5.5.0.0" newVersion="5.5.0.0" />
        </dependentAssembly>
      </assemblyBinding>
      <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
        <dependentAssembly>
          <assemblyIdentity name="System.Spatial" culture="neutral" publicKeyToken="31bf3856ad364e35" />
          <bindingRedirect oldVersion="0.0.0.0-5.5.0.0" newVersion="5.5.0.0" />
        </dependentAssembly>
      </assemblyBinding>
      <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
        <dependentAssembly>
          <assemblyIdentity name="Microsoft.Data.OData" culture="neutral" publicKeyToken="31bf3856ad364e35" />
          <bindingRedirect oldVersion="0.0.0.0-5.5.0.0" newVersion="5.5.0.0" />
        </dependentAssembly>
      </assemblyBinding>
      
      
  • Running the Azure compute emulator on the Windows 8.1 Preview- Internet Explorer in Windows 8.1 Preview has a new Enhanced Security mode which breaks the Start Without Debugging (CTRL+F5) functionality of the compute emulator. When the compute emulator starts, Internet Explorer launches and fails to load the web application hosted at the local host IP because http://127.0.0.x is not listed in Trusted sites. Start With Debugging (F5) functionality is not affected.

  • Loading the ServiceRuntime from SDK 2.0 or later in a startup task throws an exception- To resolve, add the useLegacyV2RuntimeActivationPolicy attribute with a value of true to the startup element of the App.config file for the executable, as in the following example:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
        <startup useLegacyV2RuntimeActivationPolicy="true">
             ...
             ...
             ...
        </startup>
    </configuration>
    
  • WebPI feed failure conditions-

    • The WebPI feed will fail to install if the Microsoft Root Certificate Authority 2010 or 2011 is missing.  For more information see http://support.microsoft.com/kb/931125.

    • The WebPI feed will silently fail on computers that are pending a reboot after installing updates or new software. To resolve this issue, restart the computer and then restart the setup.

See Also

Other Resources

Introducing Azure

Was this page helpful?
(1500 characters remaining)
Thank you for your feedback
Show:
© 2014 Microsoft