Exporter (0) Imprimer
Développer tout
EN
Ce contenu n’est pas disponible dans votre langue. Voici la version anglaise.

Windows Server Update Services Class Library

Purpose

Microsoft gives administrators full control over the update management process, eliminating the need for client computers to retrieve updates directly from Microsoft Update. WSUS administrators can specify the types of updates to download, create target groups of computers to receive updates, and determine which computers require updates before deployment. Administrators can approve updates for deployment automatically, uninstall updates, and generate reports to monitor update activity.

Where Applicable

System administrators can use the WSUS API to determine which updates apply to a computer or group of computers, download those updates, and install them with little or no user intervention.

Independent software vendors and end-user developers can integrate WSUS features into computer management or update management software to provide a seamless operating environment.

Developer Audience

The WSUS API is accessible by any language that supports Microsoft .NET, including Microsoft Visual Basic .NET, C#, and managed C++.

This documentation assumes that the developer is familiar with WSUS concepts and features and does not provide in-depth conceptual material. For conceptual material, see the WSUS Product Overview.

For information on the WSUS client API, see the Windows Update Agent SDK.

WSUS 3.0 Run-Time Requirements

The WSUS 3.0 API runs on Windows Server 2008, Windows Vista™, Windows Server 2003 Service Pack 1 and later, Windows XP with SP1 or SP2, and Windows 2000 with SP4. The WSUS API is available on servers that include the WSUS installation. For information about run-time requirements for a particular programming element, see the Requirements section of the reference page for that element.

ms744624.Warning(en-us,VS.85).gifWarning
WSUS 3.0 can be run on Windows 8 and Windows Server 2012. However, Windows Server supports only .NET Framework 4.0. Therefore, you may need to recompile your application to use .NET Framework 4.0 if you wish to run your application on Windows Server 2012.

Afficher:
© 2014 Microsoft