Exporter (0) Imprimer
Développer tout

Compatibilité des versions

Mise à jour : novembre 2007

Le niveau de prise en charge du .NET Framework pour la compatibilité ascendante et descendante est spécifique à la version. Le .NET Framework prend en charge la compatibilité ascendante et descendante uniquement pour les applications créées à l'aide de la version 1.1. Il ne prend pas en charge la compatibilité ascendante dans les applications créées à l'aide de la version 2.0. Dans le contexte du .NET Framework, la compatibilité descendante signifie qu'une application créée à l'aide d'une version antérieure du .NET Framework s'exécutera sur une version ultérieure. À l'inverse, la compatibilité ascendante signifie qu'une application créée à l'aide d'une version ultérieure du .NET Framework s'exécutera sur une version antérieure.

Le .NET Framework fournit un niveau élevé de prise en charge de la compatibilité descendante. Par exemple, la plupart des applications créées à l'aide de la version 1.0 s'exécuteront sur la version 1.1 et les applications créées à l'aide de la version 1.1 s'exécuteront sur la version 2.0. Le .NET Framework prend également en charge la compatibilité ascendante uniquement pour la version 1.1. Toutefois, pour la compatibilité ascendante, vous aurez peut-être besoin de modifier l'application pour qu'elle s'exécute comme prévu. Les applications créées à l'aide de la version 2.0 ne s'exécuteront pas sur les versions antérieures du .NET Framework. Qu'il s'agisse de compatibilité ascendante ou descendante, le passage à une nouvelle version du .NET Framework, s'il apporte un surcroît de sécurité, d'exactitude et de fonctionnalité, peut aussi entraîner des problèmes de compatibilité.

Pour plus d'informations sur les modifications avec rupture qui peuvent affecter votre application, consultez Modifications avec rupture dans le .NET Framework (en anglais).

Ajouts de la communauté

AJOUTER
Afficher:
© 2014 Microsoft