Exportar (0) Imprimir
Expandir todo

DateTimePicker.ValueChanged (Evento)

Actualización: noviembre 2007

Se produce cuando cambia la propiedad Value.

Espacio de nombres:  System.Windows.Forms
Ensamblado:  System.Windows.Forms (en System.Windows.Forms.dll)

public event EventHandler ValueChanged
/** @event */
public void add_ValueChanged (EventHandler value)
/** @event */
public void remove_ValueChanged (EventHandler value)

JScript no admite eventos.

Los datos proporcionados por el usuario se validan antes de que se produzca este evento. Este evento no se produce cuando la fecha especificada es anterior a MinDateTime o posterior a MaxDateTime.

Para obtener más información sobre la forma de controlar eventos, vea Utilizar eventos.

En el ejemplo de código siguiente se muestra el uso de este miembro. En el ejemplo, un controlador de eventos notifica que se ha producido el evento ValueChanged. Este informe es útil para saber cuándo se produce el evento y puede servir de ayuda en la depuración. Para informar sobre varios eventos o sobre eventos que se producen frecuentemente, considere la posibilidad de reemplazar MessageBox.Show por Console.WriteLine o de agregar el mensaje a un TextBox de varias líneas.

Para ejecutar el código de ejemplo, péguelo en un proyecto que contenga una instancia de tipo DateTimePicker con la denominación DateTimePicker1. A continuación, asegúrese de que el controlador de eventos esté asociado al evento ValueChanged.

private void DateTimePicker1_ValueChanged(Object sender, EventArgs e) {

   MessageBox.Show("You are in the DateTimePicker.ValueChanged event.");

}


Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98, Windows CE, Windows Mobile para Smartphone, Windows Mobile para Pocket PC

.NET Framework y .NET Compact Framework no admiten todas las versiones de cada plataforma. Para obtener una lista de las versiones compatibles, vea Requisitos de sistema de .NET Framework.

.NET Framework

Compatible con: 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Compatible con: 3.5, 2.0

Adiciones de comunidad

AGREGAR
Mostrar:
© 2014 Microsoft