Exportar (0) Imprimir
Expandir todo
Expandir Minimizar
Este tema aún no ha recibido ninguna valoración - Valorar este tema

OverflowAction (Enumeración)

Actualización: noviembre 2007

Especifica el modo de tratar las entradas de un registro de eventos que ha alcanzado el tamaño de archivo máximo.

Espacio de nombres:  System.Diagnostics
Ensamblado:  System (en System.dll)
public enum class OverflowAction
public enum OverflowAction
public enum OverflowAction
Nombre de miembroDescripción
DoNotOverwriteIndica que las entradas existentes se retienen cuando el registro de eventos está lleno y las entradas nuevas se descartan.
OverwriteAsNeededIndica que cada nueva entrada sobrescribe la más antigua cuando el registro de eventos está lleno.
OverwriteOlderIndica que los nuevos eventos sobrescriben los eventos anteriores a los especificados en el valor de la propiedad MinimumRetentionDays cuando el registro de eventos se llena. Los eventos nuevos se descartan si el registro de eventos está lleno y no hay eventos anteriores a los especificados en el valor de la propiedad MinimumRetentionDays.

Cada registro de eventos tiene un límite del tamaño máximo y unos valores configurables que proporcionan la regla para escribir nuevas entradas en ese límite. Puede especificar una de las siguientes reglas cuando el registro de eventos haya alcanzado su tamaño máximo:

  • Se descartarán las entradas nuevas.

  • Las entradas nuevas sobrescribirán las anteriores.

  • Las entradas nuevas se descartarán o sobrescribirán las entradas existentes en función de la edad de las entradas existentes.

El método ModifyOverflowPolicy se utiliza para establecer el comportamiento de desbordamiento de un EventLog. Compruebe el comportamiento de la configuración actual de EventLog a través de su propiedad OverflowAction.

Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98

.NET Framework y .NET Compact Framework no admiten todas las versiones de cada plataforma. Para obtener una lista de las versiones compatibles, vea Requisitos de sistema de .NET Framework.

.NET Framework

Compatible con: 3.5, 3.0, 2.0
¿Te ha resultado útil?
(Caracteres restantes: 1500)
Gracias por sus comentarios

Adiciones de comunidad

AGREGAR
Mostrar:
© 2014 Microsoft. Reservados todos los derechos.