Exportar (0) Imprimir
Expandir todo
Este artículo proviene de un motor de traducción automática. Mueva el puntero sobre las frases del artículo para ver el texto original. Más información.
Traducción
Original
Este tema aún no ha recibido ninguna valoración - Valorar este tema

BooleanSwitch.Enabled (Propiedad)

Obtiene o establece un valor que indica si el modificador está habilitado o deshabilitado.

Espacio de nombres:  System.Diagnostics
Ensamblado:  System (en System.dll)
member Enabled : bool with get, set

Valor de propiedad

Tipo: System.Boolean
true si el modificador está habilitado; en caso contrario, false. El valor predeterminado es false.
ExcepciónCondición
SecurityException

El llamador no tiene el permiso correcto.

De forma predeterminada, este campo se establece en false, es decir, está deshabilitado. Para habilitar el modificador, asigne a este campo el valor true. Para deshabilitar el modificador, asigne el valor false. El valor de esta propiedad está determinado por el valor de la propiedad de clase base SwitchSetting.

NotaNota

Este método utiliza el marcador SecurityAction.LinkDemand para impedir que se llame desde código que no es de confianza; sólo se requiere que el llamador inmediato tenga el permiso SecurityPermissionAttribute.UnmanagedCode. Si se puede llamar al código desde código de confianza parcial, no pase la entrada del usuario a métodos de la clase Marshal sin validación. Para conocer las limitaciones importantes a la hora de utilizar el miembro LinkDemand, vea Demand frente a LinkDemand.

En el siguiente código de ejemplo se crea un objeto BooleanSwitch y se utiliza el modificador para determinar si se imprimirá un mensaje de error. El modificador se crea en el nivel de clase. El método Main pasa su ubicación a MyMethod, que imprime un mensaje de error y el lugar donde se ha producido el error.

No hay ningún ejemplo de código disponible o este idioma no es compatible.

.NET Framework

Compatible con: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Compatible con: 4, 3.5 SP1

Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (no se admite el rol Server Core), Windows Server 2008 R2 (se admite el rol Server Core con SP1 o versiones posteriores; no se admite Itanium)

.NET Framework no admite todas las versiones de todas las plataformas. Para obtener una lista de las versiones compatibles, vea Requisitos de sistema de .NET Framework.
¿Te ha resultado útil?
(Caracteres restantes: 1500)
Gracias por sus comentarios

Adiciones de comunidad

AGREGAR
Mostrar:
© 2014 Microsoft. Reservados todos los derechos.