Exportar (0) Imprimir
Expandir todo
Este tema aún no ha recibido ninguna valoración - Valorar este tema

Notas de la versión de Windows Azure SDK (septiembre de 2011)

Actualizado: noviembre de 2013

Este documento contiene las notas de la versión de Windows Azure SDK versión 1.5 (septiembre de 2011).

ImportantImportante
Si instaló Windows Azure SDK versión 1.5 antes del 29 de septiembre de 2011, debe actualizar a la versión más reciente del SDK para solucionar un problema en la biblioteca cliente de almacenamiento. Para determinar si tiene la versión afectada del SDK, abra Programas y características en el Panel de control y compruebe la versión de Windows Azure SDK. Si está instalada la versión 1.5.20830.1814, tiene la versión afectada del SDK y debe actualizarlo.

Para actualizar:

  1. Haga clic en Get Tools & SDK en la página de Descargas de Windows Azure SDK. No es necesario desinstalar primero la versión 1.5.

  2. Actualice los proyectos para que utilicen la copia de Microsoft.WindowsAzure.StorageClient.dll ubicada en C:\Archivos de programa\Windows Azure SDK\v1.5\bin\.

Para obtener más información sobre el problema del cliente de almacenamiento, vea Incomplete Windows Azure Blob Download using DownloadToStream, DownloadToFile, DownloadText, and DownloadByteArray methods.

El SO invitado de Windows Azure es el sistema operativo en el que se ejecuta el servicio en la nube. Al implementar un servicio en Windows Azure, debe asegurarse de que la versión del SO invitado de Windows Azure es compatible con la versión del SDK con la que se ha desarrollado. Para obtener información detallada, vea Matriz de versiones del SO invitado de Windows Azure y compatibilidad con el SDK.

Hay dos maneras de instalar el SDK de Windows Azure. Puede descargar e instalar todo con el Instalador de plataforma web de Microsoft o puede instalar la versión independiente del SDK.

El Instalador de plataforma web de Microsoft instala automáticamente:

  1. Windows Azure Tools para Microsoft Visual Studio

  2. El SDK de Windows Azure

  3. Visual Web Developer 2010, si no dispone de Visual Studio 2010

  4. La configuración de características de IIS necesaria

  5. Las revisiones necesarias

Para instalar el Instalador de plataforma web de Microsoft y el SDK de Windows Azure, vea Instalador de plataforma web de Microsoft.

Requisitos previos para instalar y utilizar la versión independiente del SDK de Windows Azure

En esta sección se describen el software y las configuraciones que se necesitan para instalar y utilizar el SDK de Windows Azure.

  1. Microsoft .NET Framework

  2. Internet Information Services (IIS) 7.0

  3. Requisitos de base de datos para el emulador de almacenamiento de Windows Azure

  4. Actualizar desde una versión anterior del SDK

noteNota
Antes de instalar el SDK, debe salir de las versiones que se estén ejecutando de los emuladores de proceso y de almacenamiento de Windows Azure (denominados anteriormente tejido de implementación y almacenamiento de desarrollo).

El SDK está disponible en versiones de 32 y 64 bits.

  • La versión de 64 bits (x64) del SDK requiere una versión de 64 bits de Windows 7, Windows Vista Service Pack 2 o posteriores, o Windows Server 2008 SP2 o posteriores.

  • La versión de 32 bits (x86) del SDK requiere una versión de 32 bits de Windows 7, Windows Vista Service Pack 2 o posteriores, o Windows Server 2008 SP2 o posteriores.

noteNota
La versión de 32 bits del SDK no se puede instalar en un sistema operativo de 64 bits; no se admite la ejecución del SDK en Microsoft Windows de 32 bits sobre Windows 64 bits (WOW64).

El SDK de Windows Azure no se puede instalar en las ediciones Home Basic de Windows 7 o Windows Vista, ya que esas ediciones de Windows no son compatibles con IIS.

Se requiere Microsoft .NET Framework 3.5 SP1 para instalar y ejecutar el SDK de Windows Azure. Además, el SDK de Windows Azure ahora es compatible con .NET Framework 4. Tenga en cuenta que si elige instalar .NET Framework 4, también debe instalar .NET Framework 3.5 SP1 si aún no está presente en el equipo.

Si ejecuta el entorno de desarrollo de Windows Azure en un sistema operativo anterior a Windows Vista Service Pack 2 o Windows Server 2008 Service Pack 2, debe realizar una de las acciones siguientes antes de poder ejecutar un rol web que tenga como destino .NET Framework 4:

Con Windows Azure SDK versión 1.3, debe instalar IIS, incluyendo la Consola de administración de IIS. Dependiendo del tipo de servicio que vaya a generar, es posible que necesite habilitar distintos componentes de IIS 7.0. Siga el conjunto de instrucciones adecuado de los mostrados a continuación para configurar estos componentes para el sistema operativo.

  1. Haga clic en Inicio, elija Todos los programas | Programas | Herramientas administrativas y, a continuación, haga clic en Administrador del servidor.

  2. En el Administrador del servidor, en Resumen de funciones, compruebe que aparece Servidor web (IIS) en la lista de roles disponibles. Si no es así, haga clic en Agregar funciones para instalar IIS.

  3. Si tiene previsto desarrollar aplicaciones ASP.NET, haga lo siguiente:

    1. En Resumen de funciones, haga clic en Servidor web (IIS).

    2. En la ventana de administración del servidor web (IIS), haga clic en Agregar servicios de función.

    3. En el cuadro de diálogo Agregar servicios de función, en Desarrollo de aplicaciones, haga clic en ASP.NET y, a continuación, haga clic en Siguiente para instalarlo.

  4. Si tiene previsto utilizar fastCGI:

    1. En la ventana de administración del servidor web (IIS), haga clic en Agregar servicios de función.

    2. En el cuadro de diálogo Agregar servicios de función, expanda Servidor web | Desarrollo de aplicaciones y, a continuación, seleccione CGI estático.

    3. Haga clic en el botón Siguiente para instalarlo.

  1. Haga clic en Inicio y, a continuación, haga clic en Panel de control.

  2. En el Panel de control, haga clic en Programas y características.

  3. En Programas y características, haga clic en Activar o desactivar las características de Windows.

  4. Para instalar IIS y la Consola de administración de IIS, seleccione Internet Information Services

    Si tiene previsto desarrollar aplicaciones ASP.NET, expanda Internet Information Services | World Wide Web Services | Application Development Features y, a continuación, seleccione ASP.NET.

  5. Si tiene previsto utilizar fastCGI, seleccione CGI.

  6. Haga clic en Aceptar para instalar IIS y las características seleccionadas.

Se requiere QFE para FastCGI

Para utilizar FastCGI en IIS en el entorno de desarrollo de Windows Vista SP1, debe instalar el QFE siguiente:

http://support.microsoft.com/kb/967131

Este QFE no es necesario si ejecuta Windows 7, Windows Vista SP2 o Windows Server 2008.

Módulo URL Rewrite para IIS7

Si desea utilizar el módulo URL Rewrite para IIS, debe instalarlo y configurar las reglas de reescritura. Para obtener más información, vea Módulo URL Rewrite.

Si desea ejecutar los servicios para el Emulador de almacenamiento de Windows Azure, debe tener una instalación de SQL Express 2005, SQL Express 2008 o Microsoft SQL Server.

De forma predeterminada, el emulador de almacenamiento se ejecuta en una instancia de SQL Express. Para configurarlo de forma que se ejecute en una instancia local de SQL Server, llame a la herramienta DSInit con el parámetro /sqlInstance, pasando el nombre de la instancia de SQL Server de destino. Utilice el nombre de la instancia de SQL Server sin el calificador de servidor (por ejemplo, MSSQL en lugar de .\MSSQL) para hacer referencia a una instancia con nombre. Utilice “.” para hacer referencia a una instancia predeterminada o sin nombre de SQL Server.

Puede llamar a dsInit /sqlInstance en cualquier momento para configurar el emulador de almacenamiento de forma que apunte a una instancia distinta de SQL Server.

El problema siguiente puede ser aplicable si está actualizando desde una versión anterior del SDK.

  1. Para utilizar Windows Azure Tools para Microsoft Visual Studio con la versión 1.4 del SDK, debe ejecutar una edición de Visual Studio 2010 o Visual Studio 2010 Express.

  2. Si utiliza Windows Azure SDK versión 1.2 o versiones anteriores, tenga en cuenta que la versión de Microsoft.WindowsAzure.StorageClient.dll ha cambiado de 1.0.0.0 a 1.1.0.0 para admitir las nuevas características y un cambio en la forma en la que las entradas de dirección URL utilizan los caracteres de escape. El cambio de comportamiento no debería afectar a la mayoría de las aplicaciones. Sin embargo, debe actualizar las referencias de proyectos antiguas para que utilicen el nuevo ensamblado, así como volver a probar la aplicación.

Para actualizar los proyectos que utilizan Connect de Windows Azure desarrollado sobre Windows Azure SDK 1.4, debe quitar los siguientes valores de la configuración de servicio.


   <Setting name="Microsoft.WindowsAzure.Plugins.Connect.Diagnostics" value="" />
   <Setting name="Microsoft.WindowsAzure.Plugins.Connect.DNSServers" value="" />

Vea también

¿Te ha resultado útil?
(Caracteres restantes: 1500)
Gracias por sus comentarios
Mostrar:
© 2014 Microsoft. Reservados todos los derechos.