Skip to main content

Installing a .NET Framework Version Required by an Application

You may have arrived at this page because an app that you tried to run requires a specific version of the .NET Framework that is not installed on your computer. In this case, you may see an error message similar to the following:

To get the app working, install the .NET Framework by choosing one of the links below. Choose the link that matches the version number specified in the error message. For example, the error message above specifies “.NETFramework,Version=4.0”, so that is the version that you would choose from the links below. If the error message you get specifies a different version of the .NET Framework, choose the link that matches that version number.

After installing the correct version of the .NET Framework, run the app again. It should run as expected. If you see the same error message again, you may need to install a different .NET Framework version than the one you installed. It is safe to install multiple versions of the .NET Framework on your computer.

Developers should consult the .NET Framework Blog to learn how to target each of the .NET Framework platforms listed above.