Export (0) Print
Expand All

ThemeableAttribute Constructor

Initializes a new instance of the ThemeableAttribute class, using the specified Boolean value to determine whether the attribute represents a type or member that is affected by themes and control skins.

Namespace:  System.Web.UI
Assembly:  System.Web (in System.Web.dll)

public ThemeableAttribute(
	bool themeable
)

Parameters

themeable
Type: System.Boolean

true to initialize the ThemeableAttribute to represent a type or member that can be affected by themes; otherwise, false.

Passing true to this constructor is equivalent to using the Yes field, while passing false is equivalent to using the No field.

The following code example demonstrates how you can apply the ThemeableAttribute attribute to a member of a control. In this example, ThemeableAttribute is applied to a data-bound control and false is passed to the ThemeableAttribute constructor, indicating that the DataSourceID member cannot have themes applied. (Passing false to the constructor results in a ThemeableAttribute instance that is equivalent to the No field.)

namespace Samples.AspNet.CS.Controls {
    using System;
    using System.Web.UI;
    using System.Web.UI.WebControls;


    public class SomeDataBoundControl : DataBoundControl
    {
        // Implementation of a custom data source control.

        [Themeable(false) ]
        [IDReferenceProperty()]
        public override string DataSourceID {
            get {
                return base.DataSourceID;
            }
            set {
                base.DataSourceID = value;
            }
        }

    }
}

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 3.5, 3.0, 2.0

Community Additions

ADD
Show:
© 2014 Microsoft