Export (0) Print
Expand All

DataSourceView.CanUpdate Property

Gets a value indicating whether the DataSourceView object associated with the current DataSourceControl object supports the ExecuteUpdate operation.

Namespace: System.Web.UI
Assembly: System.Web (in system.web.dll)

'Declaration
Public Overridable ReadOnly Property CanUpdate As Boolean
'Usage
Dim instance As DataSourceView
Dim value As Boolean

value = instance.CanUpdate

/** @property */
public boolean get_CanUpdate ()

public function get CanUpdate () : boolean

Not applicable.

Property Value

true if the operation is supported; otherwise, false. The default implementation returns false.

The CanUpdate property reflects not only a capability of the data source control, but also whether it is currently appropriate to perform an operation. For example, even though a data-bound control supports the ExecuteUpdate operation, if a required update command or some other data is not set, the CanUpdate property returns false, as an update operation would fail.

The following code example demonstrates how to override the CanUpdate property and the ExecuteUpdate method in a class that extends the DataSourceView class. This code example is part of a larger example provided for the DataSourceView class.

   ' The CsvDataSourceView does not currently
   ' permit update operations. You can modify or
   ' extend this sample to do so.
   Public Overrides ReadOnly Property CanUpdate() As Boolean
      Get
         Return False
      End Get
   End Property

   Protected Overrides Function ExecuteUpdate(keys As IDictionary, _
                                              values As IDictionary, _
                                              oldValues As IDictionary) As Integer
      Throw New NotSupportedException()
   End Function 'ExecuteUpdate

End Class 'CsvDataSourceView

Windows 98, Windows Server 2000 SP4, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The Microsoft .NET Framework 3.0 is supported on Windows Vista, Microsoft Windows XP SP2, and Windows Server 2003 SP1.

.NET Framework

Supported in: 3.0, 2.0

Community Additions

ADD
Show:
© 2014 Microsoft