Export (0) Print
Expand All

UCOMITypeLib Interface

NOTE: This interface is now obsolete.

Use System.Runtime.InteropServices.ComTypes.ITypeLib instead.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

[ObsoleteAttribute("Use System.Runtime.InteropServices.ComTypes.ITypeLib instead. http://go.microsoft.com/fwlink/?linkid=14202", false)] 
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIUnknown)] 
[GuidAttribute("00020402-0000-0000-C000-000000000046")] 
public interface UCOMITypeLib
/** @attribute ObsoleteAttribute("Use System.Runtime.InteropServices.ComTypes.ITypeLib instead. http://go.microsoft.com/fwlink/?linkid=14202", false) */ 
/** @attribute InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIUnknown) */ 
/** @attribute GuidAttribute("00020402-0000-0000-C000-000000000046") */ 
public interface UCOMITypeLib
ObsoleteAttribute("Use System.Runtime.InteropServices.ComTypes.ITypeLib instead. http://go.microsoft.com/fwlink/?linkid=14202", false) 
InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIUnknown) 
GuidAttribute("00020402-0000-0000-C000-000000000046") 
public interface UCOMITypeLib
Not applicable.

For additional information about the ITypeLib interface, see the MSDN Library.

Windows 98, Windows Server 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The Microsoft .NET Framework 3.0 is supported on Windows Vista, Microsoft Windows XP SP2, and Windows Server 2003 SP1.

.NET Framework

Supported in: 1.0, 1.1, 2.0
Obsolete (compiler warning) in 3.0

Community Additions

ADD
Show:
© 2014 Microsoft