Export (0) Print
Expand All
Expand Minimize
This topic has not yet been rated - Rate this topic

OpCodes.Starg_S Field

Stores the value on top of the evaluation stack in the argument slot at a specified index, short form.

Namespace:  System.Reflection.Emit
Assembly:  mscorlib (in mscorlib.dll)
public static readonly OpCode Starg_S

The following table lists the instruction's hexadecimal and Microsoft Intermediate Language (MSIL) assembly format, along with a brief reference summary:

Format

Assembly Format

Description

10 < unsigned int8 >

starg.s num

Pops the top value from the stack and stores it in argument slot num, short form.

The stack transitional behavior, in sequential order, is:

  1. The value currently on top of the stack is popped and placed in argument slot num.

The starg.s instruction pops a value from the stack and places it in argument slot num. The type of the value must match the type of the argument, as specified in the current method's signature.

The starg.s instruction provides an efficient encoding for use with the first 256 arguments.

For procedures that take a variable argument list, the starg.s instruction can be used only for the initial fixed arguments, not those in the variable part of the signature.

Performing a store into arguments that hold an integer value smaller than 4 bytes long truncates the value as it moves from the stack to the argument. Floating-point values are rounded from their native size (type F) to the size associated with the argument.

The following Emit method overload can use the starg.s opcode:

  • ILGenerator.Emit(OpCode, byte)

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 3.5, 3.0, 2.0, 1.1, 1.0
Did you find this helpful?
(1500 characters remaining)
Thank you for your feedback

Community Additions

ADD
Show:
© 2014 Microsoft. All rights reserved.