Export (0) Print
Expand All

ServicePoint.ProtocolVersion Property

Gets the version of the HTTP protocol that the ServicePoint object uses.

Namespace:  System.Net
Assembly:  System (in System.dll)

'Declaration
Public Overridable ReadOnly Property ProtocolVersion As Version
'Usage
Dim instance As ServicePoint 
Dim value As Version 

value = instance.ProtocolVersion

Property Value

Type: System.Version
A Version object that contains the HTTP protocol version that the ServicePoint object uses.

The HTTP protocol versions are HTTP/1.0 and HTTP/1.1.

The following code example displays the value of this property.

If sp.Certificate Is Nothing Then
    Console.WriteLine("Certificate = (null)")
Else
    Console.WriteLine(("Certificate = " + sp.Certificate.ToString()))
End If 

If sp.ClientCertificate Is Nothing Then
    Console.WriteLine("ClientCertificate = (null)")
Else
    Console.WriteLine(("ClientCertificate = " + sp.ClientCertificate.ToString()))
End If

Console.WriteLine("ProtocolVersion = " + sp.ProtocolVersion.ToString())
Console.WriteLine(("SupportsPipelining = " + sp.SupportsPipelining.ToString()))
if (sp->Certificate == 0)
    Console::WriteLine(S"Certificate = (null)");
else
    Console::WriteLine(S"Certificate = {0}", sp->Certificate);

if (sp->ClientCertificate == 0)
    Console::WriteLine(S"Client Certificate = (null)");
else
    Console::WriteLine(S"Client Certificate = {0}", sp->ClientCertificate);

Console::WriteLine(S"ProtocolVersion = {0}", sp->ProtocolVersion->ToString());
Console::WriteLine(S"SupportsPipelining = {0}", __box(sp->SupportsPipelining));

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98, Windows CE, Windows Mobile for Smartphone, Windows Mobile for Pocket PC

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

Community Additions

ADD
Show:
© 2014 Microsoft