Export (0) Print
Expand All
Expand Minimize

PropertyAttributes Enumeration

NOTE: This API is now obsolete.

Specifies the attributes of a property.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace:  System.Data
Assembly:  System.Data (in System.Data.dll)

[FlagsAttribute]
[ObsoleteAttribute(L"PropertyAttributes has been deprecated.  http://go.microsoft.com/fwlink/?linkid=14202")]
public enum class PropertyAttributes

Member nameDescription
Supported by the .NET Compact FrameworkSupported by the XNA FrameworkNotSupportedThe property is not supported by the provider.
Supported by the .NET Compact FrameworkSupported by the XNA FrameworkRequiredThe user must specify a value for this property before the data source is initialized.
Supported by the .NET Compact FrameworkSupported by the XNA FrameworkOptionalThe user does not need to specify a value for this property before the data source is initialized.
Supported by the .NET Compact FrameworkSupported by the XNA FrameworkReadThe user can read the property.
Supported by the .NET Compact FrameworkSupported by the XNA FrameworkWriteThe user can write to the property.

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98, Windows CE, Windows Mobile for Smartphone, Windows Mobile for Pocket PC, Xbox 360, Zune

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 1.1, 1.0
Obsolete (compiler warning) in 3.5
Obsolete (compiler warning) in 3.5 SP1
Obsolete (compiler warning) in 3.0
Obsolete (compiler warning) in 3.0 SP1
Obsolete (compiler warning) in 3.0 SP2
Obsolete (compiler warning) in 2.0
Obsolete (compiler warning) in 2.0 SP1
Obsolete (compiler warning) in 2.0 SP2

.NET Compact Framework

Supported in: 1.0
Obsolete (compiler warning) in 3.5
Obsolete (compiler warning) in 2.0

XNA Framework

Obsolete (compiler warning) in 3.0
Obsolete (compiler warning) in 2.0
Obsolete (compiler warning) in 1.0

Community Additions

ADD
Show:
© 2014 Microsoft