Export (0) Print
Expand All
This topic has not yet been rated - Rate this topic

ComponentInstaller.IsEquivalentInstaller Method

Determines if the specified installer installs the same object as this installer.

Namespace:  System.Configuration.Install
Assembly:  System.Configuration.Install (in System.Configuration.Install.dll)
public virtual bool IsEquivalentInstaller(
	ComponentInstaller otherInstaller
)

Parameters

otherInstaller
Type: System.Configuration.Install.ComponentInstaller

The installer to compare.

Return Value

Type: System.Boolean
true if this installer and the installer specified by the otherInstaller parameter install the same object; otherwise, false.

Typically, IsEquivalentInstaller returns true only if this installer and the installer specified by the otherInstaller parameter install the same object. In such a case, calling the Install or Uninstall method on either installer results in the same system state.

The following example defines a class MyInstallClass, which creates the event log and copies the properties of the event log component to the EventLogInstaller object. It also checks whether ServiceInstaller object can handle the same kind of installation as EventLogInstaller.

ServiceInstaller myServiceInstaller = new  ServiceInstaller();
// Check whether 'ServiceInstaller' object can handle the same  
// kind of installation as 'EventLogInstaller' object. 
if(myEventLogInstaller.IsEquivalentInstaller(myServiceInstaller))
{
   Console.WriteLine("'ServiceInstaller' can handle the same kind" 
                     +" of installation as EventLogInstaller");
}
else
{
    Console.WriteLine("'ServiceInstaller' can't handle the same" 
                 +" kind of installation as 'EventLogInstaller'");
}

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 3.5, 3.0, 2.0, 1.1, 1.0
Did you find this helpful?
(1500 characters remaining)
Thank you for your feedback

Community Additions

ADD
Show:
© 2014 Microsoft. All rights reserved.