Export (0) Print
Expand All
Expand Minimize

UpdateMode Enumeration

This enumeration supports the .NET Framework infrastructure and is not intended to be used directly from your code.

Provides constants for compatibility with the Visual Basic 6.0 UpdateMode method.

Namespace: Microsoft.VisualBasic.Compatibility.VB6
Assembly: Microsoft.VisualBasic.Compatibility.Data (in microsoft.visualbasic.compatibility.data.dll)

[GuidAttribute("4BFADC70-4994-11D1-A3A8-00A0C90F26FA")] 
public enum UpdateMode
/** @attribute GuidAttribute("4BFADC70-4994-11D1-A3A8-00A0C90F26FA") */ 
public enum UpdateMode
GuidAttribute("4BFADC70-4994-11D1-A3A8-00A0C90F26FA") 
public enum UpdateMode

 Member nameDescription
vbUpdateWhenPropertyChanges
vbUpdateWhenRowChanges
vbUsePropertyAttributes

These constants enable code that has been upgraded from Visual Basic 6.0 to continue to run without additional modification.

NoteNote:

Functions and objects in the Microsoft.VisualBasic.Compatibility.VB6 namespace are provided for use by the tools for upgrading from Visual Basic 6.0 to Visual Basic Code Name "Orcas". In most cases, these functions and objects duplicate functionality that you can find in other namespaces in the .NET Framework. They are necessary only when the Visual Basic 6.0 code model differs significantly from the .NET Framework implementation.

Windows 98, Windows Server 2000 SP4, Windows CE, Windows Millennium Edition, Windows Mobile for Pocket PC, Windows Mobile for Smartphone, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The Microsoft .NET Framework 3.0 is supported on Windows Vista, Microsoft Windows XP SP2, and Windows Server 2003 SP1.

.NET Framework

Supported in: 3.0

Community Additions

ADD
Show:
© 2014 Microsoft