Export (0) Print
Expand All

IAppxManifestPackageDependency::GetMinVersion method

Gets the minimum version of the package on which the current package has a dependency.

Syntax


HRESULT GetMinVersion(
  [out]  UINT64 *minVersion
);

Parameters

minVersion [out]

Type: UINT64*

The minimum version of the package.

Return value

Type: HRESULT

If this method succeeds, it returns S_OK. Otherwise, it returns an HRESULT error code.

Remarks

If the minimum version is not defined for the dependency, this method returns S_OK and minVersion is 0.

The version is specified using the MinVersion attribute of the PackageDependency element in the package manifest. The specification in the manifest is in quad notation:

major.minor.build.revision

This method converts this notation to a UINT64 value as follows:

  • The high-order word contains the major version
  • The next word contains the minor version
  • The next word contains the build number
  • The low-order word contains the revision

Requirements

Minimum supported client

Windows 8 [desktop apps only]

Minimum supported server

Windows Server 2012 [desktop apps only]

Header

AppxPackaging.h

IDL

AppxPackaging.idl

IID

IID_IAppxManifestPackageDependency is defined as e4946b59-733e-43f0-a724-3bde4c1285a0

See also

IAppxManifestPackageDependency

 

 

Show:
© 2014 Microsoft