Export (0) Print
Expand All

Install Critical Windows Updates

Before installing Microsoft AppFabric 1.1 for Windows Server or its prerequisites, use the following procedures to install the latest critical Microsoft updates for your version of Windows, and any available recommended update.

Versions of Windows supported in this release are Windows 7, Windows 8, Windows Vista Service Pack 2, Windows Server 2008 Service Pack 2, Windows Server 2008 R2, and Windows Server 2012. For production scenarios, only Windows Server 2008 SP2, Windows Server 2008 R2, and Windows Server 2012 are supported. For development scenarios, Windows 7, Windows 8, and Windows Vista SP2 are also supported. Pre-release versions of these operating systems (betas or release candidates) are not supported.

noteNote
Installation of AppFabric Hosting Services, Caching Services, Hosting Administration, and Cache Administration is not supported on the Web Edition or Foundation Edition of Windows Server 2008 R2 or Windows Server 2008 SP2. Installation of the AppFabric Cache Client is supported on Windows Server Web Edition or Foundation Edition.

Install Windows Updates

  1. Click Start, point to All Programs, and then click Windows Update.

  2. Follow the directions on the Windows Update site.

  3. If prompted, restart your computer.

Install Hotfixes

The following sections list recommended updates for Windows Server AppFabric 1.0 and Microsoft AppFabric 1.1 for Windows Server respectively.

ImportantImportant
If you are viewing this topic from the in-product help file, you should refer to the online version of this topic for the latest updates: Recommended Updates for Windows Server AppFabric (http://go.microsoft.com/fwlink/?LinkID=185864).

Updates for Windows Server AppFabric 1.0

If you are using Windows 7 Service Pack 1 or Windows Server 2008 R2 Service Pack 1, you do not require any known updates at this time. However, users of these operating systems without the service pack update should apply the following updates.

 

KB980423

You must install KB980423 to fix a set of issues caused by Microsoft Web Administration (MWA). After you install this item, you may have to restart your computer.

KB983484

You must install KB983484 to prevent some services from being preloaded unexpectedly when you start a website that contains multiple applications in IIS 7.5. After you install this item, you may have to restart your computer.

Updates for Microsoft AppFabric 1.1 for Windows Server

If you are using Windows 7 Service Pack 1, Windows 8, or Windows Server 2008 R2 Service Pack 1, you do not require any known updates at this time. However, users of Windows 7 and Windows 2008 R2 without the associated service pack update should apply the following updates.

 

KB980423

You must install KB980423 to fix a set of issues caused by Microsoft Web Administration (MWA). After you install this item, you may have to restart your computer.

KB983484

You must install KB983484 to prevent some services from being preloaded unexpectedly when you start a website that contains multiple applications in IIS 7.5. After you install this item, you may have to restart your computer.

  2012-10-26
Show:
© 2014 Microsoft