Export (0) Print
Expand All

Verify JavaScript framework support for the latest versions of Internet Explorer

Each version of Windows Internet Explorer improves support for modern standards and interoperability with other web browsers.

Most of these frameworks have already been updated to work correctly in the latest version of Internet Explorer. However, many sites are still using older versions of JavaScript frameworks that are not compatible with the latest version of Internet Explorer.

Many existing JavaScript frameworks contained functionality that was dependent upon existing Internet Explorer-specific behavior or quirks. Consequently, the changes made in Internet Explorer may cause part of many popular JavaScript frameworks to stop working correctly.

If your site relies on a JavaScript framework and you are encountering issues with Internet Explorer, try updating to the latest version of the framework.

To demonstrate, here is a list of popular JavaScript frameworks that needed to be updated to support Windows Internet Explorer 9:

FrameworkIE-Compatible VersionsGet the Latest Version From
Cufon1.09i+http://cufon.shoqolate.com/generate/
jQuery1.5.1+http://jquery.com/
jQuery UI1.6.8+http://jqueryui.com/
MooTools1.3+http://mootools.net/
Prototype1.7+http://prototypejs.org/

 

NOTE: Frameworks that are not listed in the previous table might have a newer version that is compatible with Internet Explorer, so upgrading to the latest version of a framework remains the correct initial course of action to resolve compatibility issues. Share your knowledge of the compatibility status of other frameworks in the comments below.

 

 

Show:
© 2014 Microsoft