Export (0) Print
Expand All

Prerequisites for WCF RIA Services

WCF RIA Services

[WCF RIA Services Version 1 Service Pack 2 is compatible with either .NET framework 4 or .NET Framework 4.5, and with either Silverlight 4 or Silverlight 5.]

The walkthroughs and other demonstrations presented in the WCF RIA Services SP2 documentation require several prerequisite programs be installed and configured. Detailed instructions are provided in this section for the satisfaction of these prerequisites, to ensure that the end user encounters as few problems as possible when getting setup to work through the RIA Services walkthroughs and, more generally, when using the product.

Visual Studio 2010 or Visual Studio 2012, the Silverlight Developer Runtime, SDK, and Toolkit and WCF RIA Services and its Toolkit must be installed before attempting to complete the RIA Services walkthroughs. Entity Framework 4.1 is also needed for the code-first approach walkthrough. Here are the installation points for these programs:

  • Visual Web Developer 2010 Express or any retail version of Visual Studio 2010 or 2012. Click on the Install Now button to install this version of Visual Studio 2010 and the latest components of the Microsoft Web Platform.

    Caution note Caution

    If you are using an express, and not a retail, version of Visual Studio 2010, then you must install the Visual Web Developer 2010 Express edition to use RIA Services. Other express editions will not work.

  • Visual Studio 2010 SP1, which will upgrade any version of Visual Studio 2010.

    Note Note

    This upgrade is, in fact, optional as RIA Services SP2 will work with one of the versions of Visual Studio 2010 installed in accordance with the instructions above.

  • Microsoft Silverlight 5 Tools for Visual Studio 2010 SP1 installs all the Silverlight runtime and SDK, and WCF RIA Services SP2, but not the latest RIA Services Toolkit.

    Note Note

    It is not necessary to uninstall Silverlight 4 SDK, as RIA Services SP2 will work with Silverlight 5 SDK and Silverlight 4 SDK installed side by side on the machine.

    Note Note

    Note that it is not necessary to uninstall earlier versions of RIA Services as the RIA Services MSI will upgrade earlier versions of the product.

  • The latest version of the RIA Services Toolkit is available from WCF RIA Services and Toolkit.

    Caution note Caution

    Earlier version of the RIA Services Toolkit must be uninstalled before installing the latest version.

  • ADO.NET Entity Framework 4.1 Update 1 is required to use the new code first feature available in RIA Services v1 SP2.

Caution note Caution

Silverlight has two runtimes: one for end users and one for developers. Installing the Silverlight Developer Runtime is a precondition for installing RIA Services. Having the end user runtime installed will also cause various issues during Silverlight development itself. If, for example, you get a message that you are unable to start debugging because the Silverlight Developer Runtime is not installed, then you have the wrong runtime installed and need to replace it with the developer runtime.

Caution note Caution

To use cloud storage via SQL Azure with RIA Services applications, you need to have the ASP.NET Universal Providers that add provider support in ASP.NET 4 for SQL Azure. These providers also support all editions of SQL Server 2005 and later. These are installed with Visual Studio 2012, but need to be installed using the Nuget Package Manager for relevant projects in Visual Studio 2010. For instructions on how to do this, see Universal Providers enable Cloud-based Storage in RIA Services

There are more detailed walkthroughs provided in this section for the two additional prerequisites: installing and configuring SQL Server 2008 R2 Express with Advanced Services and installing the AdventureWorks OLTP and LT database.

Show:
© 2014 Microsoft