Export (0) Print
Expand All

Target Audience and System Requirements

This guidance is intended for software architects and software developers. To get the greatest benefit from this guidance, you should have an understanding of the following technologies:

  • Microsoft Visual C#® or Microsoft Visual Basic® .NET
  • Microsoft .NET Framework

The following are the system requirements for using Enterprise Library:

  • Supported architectures: x86 and x64.
  • Operating system: Microsoft Windows® 7 Professional, Enterprise, or Ultimate; Windows Server® 2003 R2; Windows Server 2008 with Service Pack 2; Windows Server 2008 R2; Windows Vista® with Service Pack 2; or Windows XP with Service Pack 3.
  • Microsoft .NET Framework 3.5 with Service Pack 1 or Microsoft .NET Framework 4.0.
  • For a rich development environment and use of the integrated configuration tool, the following are recommended:
    • Microsoft Visual Studio® 2008 Development System with Service Pack 1 (any edition) or Microsoft Visual Studio 2010 Development System (any edition)
  • To run the unit tests, the following are also required:
    • Microsoft Visual Studio 2008 Professional, Visual Studio 2008 Team Edition, Visual Studio 2010 Premium, Visual Studio 2010 Professional, or Visual Studio 2010 Ultimate edition
    • Moq v3.1 assemblies.
  • For the Data Access Application Block, the following is also required:
    • A database server running a database that is supported by a .NET Framework 3.5 with Service Pack 1 or .NET Framework 4.0 data provider. This includes SQL Server® 2000 or later, SQL Server 2005 Compact Edition, and Oracle 9i or later. The database server can also run a database that is supported by the .NET Framework 3.5 with Service Pack 1 or the .NET Framework 4.0 data providers for OLE DB or ODBC.
  • For the Logging Application Block, the following is also required:
    • Stores to maintain log messages. If you are using the MsmqTraceListener trace listener to store log messages, you need the Windows Message Queuing component called MSMQ installed. If you are using the DatabaseTraceListener trace listener to store log messages, you need access to a database server. If you are using the EmailTraceListener trace listener to store log messages, you need access to an SMTP server.

If some of these dependencies are not met, you may not be able to use certain Enterprise Library features. You should ensure these dependencies are satisfied before continuing.


Ff664482.note(en-us,PandP.50).gifNote:
Unity is a general-purpose dependency injection mechanism designed for use in applications that run on the .NET Framework. It is not limited to use only within Enterprise Library. For details of the system requirements and development software requirements for Unity, see Target Audience and System Requirements in the Unity section of this guidance.


Show:
© 2014 Microsoft