Export (0) Print
Expand All

Upgrade Advisor Prerequisites

SQL Server 2014

This topic describes the software requirements for Upgrade Advisor.

The prerequisites for installing and running Upgrade Advisor are as follows:

  • Windows Vista SP1, Windows Server 2008 beginning with SP2, Windows 7, or Windows Server 2008 R2.

  • Windows Installer 4.5. You can install Windows Installer from the Windows Installer Web site.

  • The .NET Framework, beginning with .NET Framework 4. The .NET Framework is available on the SQL Server 2014 product media, and from the SDK, redistributable, and service pack download Web site.

    • To install the .NET Framework 4 from the SQL Server 2014 media, locate the root of the disk drive. Then double-click the \redist folder, double-click the DotNetFrameworks folder, and run dotNetFx40_Full_x86_x64.exe (for both 32-bit and 64-bit operating systems).

  • The Microsoft SQL Server Transact-SQL ScriptDom is a prerequisite for installing SQL Server 2014 Upgrade Advisor, and is not installed by Upgrade Advisor Setup. The Setup requires you to download and install the Microsoft SQL Server Transact-SQL ScriptDom from the SQL Server 2014 Feature Pack.

Community Additions

ADD
Show:
© 2014 Microsoft